Cyberduck Mountain Duck CLI

#10020 closed defect (worksforme)

Unable to upload files with ftps

Reported by: teras Owned by: dkocher
Priority: normal Milestone: 6.3
Component: ftp-tls Version: 6.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

I am trying to use cyberduck with ftps, but with no luck. (note: ftps, not sftp)

Up to now I am successful to connect to my ftps site, list content and delete files. What I can not do, is upload file. Note that with lftp from the command line I am able to do so. Another thing is that the certificate is self signed, but it is properly trusted in my keychain (as far as I can see). And I connect passively to the server explicitly.

The upload folder is "backup" and it is chrooted. Here is the log file:

STAT /backups
213-Status follows:
drwxr-xr-x    2 1003     1003         4096 Jul 22 09:34 .
drwxr-xr-x    3 0        1003         4096 Jul 22 08:50 ..
213 End of status
TYPE I
200 Switching to Binary mode.
PASV
227 Entering Passive Mode (0,0,0,0,250,117).
TYPE I
200 Switching to Binary mode.
PASV
227 Entering Passive Mode (0,0,0,0,254,5).
TYPE I
200 Switching to Binary mode.
PASV
227 Entering Passive Mode (0,0,0,0,255,25).
TYPE I
200 Switching to Binary mode.
PASV
227 Entering Passive Mode (0,0,0,0,255,172).
QUIT
221 Goodbye.

Change History (2)

comment:1 Changed on Aug 21, 2017 at 8:15:56 AM by dkocher

  • Component changed from core to ftp-tls
  • Owner set to dkocher

comment:2 Changed on Aug 21, 2017 at 10:10:26 AM by dkocher

  • Milestone set to 6.3
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue.

Note: See TracTickets for help on using tickets.
swiss made software