Cyberduck Mountain Duck CLI

#10079 assigned defect

Does not upload edited files when more than two files are opened

Reported by: jichan3751 Owned by: dkocher
Priority: high Milestone: 7.0
Component: core Version: 6.2.6
Severity: normal Keywords:
Cc: Architecture: Intel
Platform:

Description

When I open 2 files with sublime text for edit, bug happens. I'm using cyberduck mac to connect sftp server of Ubuntu with 'double click opens file in external editor' option turned on.

Here is the reproducable bug routine:

  1. open file1.py
  2. edit file1.py, but do not save
  3. open file2.py
  4. edit file2.py. save. Uploading works.
  5. now save file1.py. Uploading is not working.

Change History (11)

comment:1 Changed on Oct 6, 2017 at 6:08:25 PM by dkocher

  • Milestone set to 6.3
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 follow-up: Changed on Oct 9, 2017 at 12:33:38 PM by dkocher

I cannot reproduce this bug. What external editor do you use?

comment:3 Changed on Oct 9, 2017 at 12:34:09 PM by dkocher

#10099 closed as duplicate.

comment:4 Changed on Oct 9, 2017 at 12:34:20 PM by dkocher

#10080 closed as duplicate.

comment:5 Changed on Oct 11, 2017 at 8:26:09 AM by dkocher

#10083 closed as duplicate.

comment:6 in reply to: ↑ 2 Changed on Oct 11, 2017 at 1:25:25 PM by dkardell

Replying to dkocher:

I cannot reproduce this bug. What external editor do you use?

This is happening to me with SublimeText3 on Latest Mac OS

comment:7 Changed on Oct 13, 2017 at 12:16:44 PM by dkocher

  • Component changed from sftp to core

comment:8 Changed on Nov 13, 2017 at 4:24:53 PM by dkocher

  • Milestone changed from 6.3 to 7.0

Ticket retargeted after milestone closed

comment:9 Changed on Jan 10, 2018 at 10:34:35 AM by dkocher

Unfortunately I still cannot reproduce the problem testing with Sublime Text.

comment:10 Changed on Jan 10, 2018 at 1:42:41 PM by dkardell

Its very hit and miss. One day I can go all day without hitting it and yet in another the first time I open a php file, update and save it.. it does not make it back to the server. However I can open up yet another file and make a change and save it and that file saves. Almost like it gets confused as to the "state" of the modified file? I use all GoDaddy servers so not sure if that has anything to do with it.

comment:11 Changed on Feb 28, 2018 at 4:08:39 PM by ojalaquellueva

The behavior I reported earlier (see closed duplicate #10099) is similar, however it is not necessary to open two files at once. Sometimes I open and close a single file multiple times while editing locally with TextWrangler as the default editor. After an unpredictable number of cycles of open-->edit-->save-->close Cyberduck suddenly stops saving to the remote server. My workaround is to choose File-->Save from the TextWrangler menus instead of just closing and responding the TextWrangler prompt to save...it won't if Cyberduck has disconnected the file from the server. I then watch the Cyberduck interface to observe if it is transmitting the change to the server. When Cyberduck stops responding, hitting the "refresh" button fixes the problem for a while, until the next disconnect.

TextWrangler 5.5.2 OSX 10.13.2

Note: See TracTickets for help on using tickets.
swiss made software