Cyberduck Mountain Duck CLI

#10094 closed defect (fixed)

Use of symbolic link for application support folder

Reported by: luckman212 Owned by: dkocher
Priority: normal Milestone: 6.2.9
Component: core Version: 6.2.6
Severity: normal Keywords: bookmarks, symlink, hardlink
Cc: Architecture:
Platform: macOS 10.13

Description

Cyberduck Version 6.2.6 (26405) MountainDuck 2.0.2 (8111) Tested on macOS 10.12.6 and 10.13

I like to share my bookmarks between 3 computers. For this I use ResilioSync (used to be BTSync). The way I do this for all my other apps is, move the config folder to the Sync folder and then create a Symlink in the original spot for it to read from. This works for all other apps but not for Cyberduck/MountainDuck. They refuse to acknowledge the symlink and either hang when launched (Cyberduck) or just show no bookmarks (MountainDuck).

I had "solved" this in 10.12 using Hardlink instead of Symlink - which did work, however now that I am on 10.13 with APFS filesystem, hardlinks are no longer supported and so this is not working again.

Please if you can support the fact that the bookmarks folder might be a Symlink that would be excellent

Change History (9)

comment:1 Changed on Oct 11, 2017 at 2:40:57 PM by dkocher

  • Summary changed from Cyberduck (and Mountain Duck) do not properly handle symlinked config folders to Use of symbolic link for application support folder

comment:2 Changed on Oct 11, 2017 at 2:41:46 PM by dkocher

  • Milestone set to 6.2.9
  • Resolution set to fixed
  • Status changed from new to closed

I have linked the application support folder to a directory in my home folder with ln -s ~/duck ~/Library/Group\ Containers/G69SCX94XU.duck/Library/Application\ Support/duck and could not reproduce the issue.

comment:3 Changed on Oct 11, 2017 at 2:52:11 PM by luckman212

Thanks for looking into this but I think there's an issue still. It may work to symlink the entire "duck" folder however that is not what I am doing (I only want to sync Bookmarks - also it is probably not wise or even viable to sync the whole folder because the mountpoints are also stored there. Not sure what horrible things might happen if it's being used on 2 machines and both have the same bookmark mounted...) So I am only symlinking my "Bookmarks" folder. Here's a repro. I just tested this with MountainDuck 2.0.3(snap)

  1. quit MountainDuck
  1. open Terminal and run these commands
cd "$HOME/Library/Group Containers/G69SCX94XU.duck/Library/Application Support/duck"
mv Bookmarks "$HOME/duck-bookmarks-test"
ln -siv "$HOME/duck-bookmarks-test" Bookmarks
  1. relaunch MountainDuck

no bookarks will be shown...

comment:4 Changed on Oct 11, 2017 at 2:59:44 PM by luckman212

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed on Oct 12, 2017 at 7:05:08 PM by dkocher

  • Owner set to dkocher
  • Status changed from reopened to new
Caused by: ch.cyberduck.core.exception.LocalAccessDeniedException{detail='Ordner /Users/dkocher/Library/Group Containers/G69SCX94XU.duck/Library/Application Support/duck/Bookmarks kann nicht angelegt werden', cause='java.nio.file.FileAlreadyExistsException: /Users/dkocher/Library/Group Containers/G69SCX94XU.duck/Library/Application Support/duck/Bookmarks', message='Access denied'}
	at ch.cyberduck.core.Local.mkdir(Local.java:194)
	at ch.cyberduck.core.AbstractFolderHostCollection.load(AbstractFolderHostCollection.java:125)
	at ch.cyberduck.core.BookmarkCollection.load(BookmarkCollection.java:246)

comment:6 Changed on Oct 12, 2017 at 7:05:12 PM by dkocher

  • Status changed from new to assigned

comment:7 Changed on Oct 13, 2017 at 7:28:38 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r42898.

comment:8 Changed on Oct 13, 2017 at 8:15:55 AM by dkocher

Note that despite the fix this will not work when running the application sandboxed (running from the Mac App Store).

comment:9 Changed on Oct 16, 2017 at 9:52:01 PM by luckman212

Just wanted to confirm that this bug is fixed as of MountainDuck 2.0.3 (8407) and Cyberduck 6.2.9 (26659) Thank you very much!!

Note: See TracTickets for help on using tickets.
swiss made software