Cyberduck Mountain Duck CLI

#101 closed defect (worksforme)

NoClassDefFoundError: org/apache/log4j/Logger at

Reported by: michele.zucali@… Owned by: dkocher
Priority: normal Milestone: 2.5.4
Component: core Version: 2.5.3
Severity: blocker Keywords:
Cc: Architecture:
Platform:

Description

Stack Trace: java.lang.ExceptionInInitializerError

at ch.cyberduck.ui.cocoa.CDBrowserController.init(CDBrowserController.java:2121) at ch.cyberduck.ui.cocoa.CDBrowserController.mount(CDBrowserController.java:2301) at ch.cyberduck.ui.cocoa.CDBrowserController.mount(CDBrowserController.java:2273) at ch.cyberduck.ui.cocoa.CDConnectionController.callback(CDConnectionController.java:582) at ch.cyberduck.ui.cocoa.CDSheetController.sheetDidClose(CDSheetController.java:167) at com.apple.cocoa.application.NSApplication.endSheetReturnCodeNative(Native Method) at com.apple.cocoa.application.NSApplication.endSheet(NSApplication.java:367) at ch.cyberduck.ui.cocoa.CDSheetController.closeSheet(CDSheetController.java:80)

Caused by: org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@e312 for org.apache.commons.logging.impl.Log4JLogger

at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:532) at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:272) at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:246) at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:395) at com.sshtools.j2ssh.transport.AbstractKnownHostsKeyVerification.<clinit>(AbstractKnownHostsKeyVerification.java:58) ... 8 more

Caused by: org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@e312 for org.apache.commons.logging.impl.Log4JLogger

at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:432) at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:525) ... 12 more

Caused by: java.lang.NoClassDefFoundError: org/apache/log4j/Logger

at java.lang.Class.getDeclaredConstructors0(Native Method) at java.lang.Class.privateGetDeclaredConstructors(Class.java:1618) at java.lang.Class.getConstructor0(Class.java:1930) at java.lang.Class.getConstructor(Class.java:1027) at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:429) ... 13 more

Change History (5)

comment:1 Changed on Jan 11, 2006 at 9:02:05 AM by dkocher

This looks like a corrupt installation of Cyberduck. Please redownload and see if it is still an issue.

comment:2 Changed on Jan 16, 2006 at 11:51:59 PM by dkocher

  • Milestone changed from 2.6 to 2.5.4
  • Severity changed from normal to blocker
  • Status changed from new to assigned

comment:3 Changed on Jan 17, 2006 at 12:02:45 AM by dkocher

  • Summary changed from every time using sftp to NoClassDefFoundError: org/apache/log4j/Logger at

comment:4 Changed on Jan 19, 2006 at 4:46:54 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

Cannot reproduce.

comment:5 Changed on Aug 28, 2009 at 7:35:33 AM by samj

Looks the same as #3641 - may be some useful debugging info here.

Note: See TracTickets for help on using tickets.
swiss made software