Cyberduck Mountain Duck CLI

#10128 closed defect (worksforme)

Password not saved in keychain

Reported by: mrpooh Owned by: David Levingston
Priority: normal Milestone: 6.3.1
Component: core Version: 6.2.10
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: macOS 10.12

Description

Greetings,

I am using a new iMac running Sierra.

I am trying Cyberduck (download the most recent version) and I find that each time I want to open a bookmark to access my website I am required to enter my password, even though I have checked the box to allow the password to be saved to the keychain. And sometimes I have to enter my password to upload files to the website.

Will this feature/behavior change if I make a donation or pay some money?

Is this a problem or the way it's supposed to work? It's cumbersome to have to enter my password each time I want to access my website. I can't imagine why I am being asked for the password each time and it won't be saved.

Can you help me figure out why the password isn't saving?

Thank you,

David

Change History (3)

comment:1 Changed on Nov 7, 2017 at 8:52:05 AM by dkocher

  • Summary changed from Will Cyberduck save my passwords to the keychain if I make a donation? to Password not saved in keychain

comment:2 Changed on Nov 27, 2017 at 12:41:00 PM by dkocher

  • Milestone set to 6.3.1
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue. Please try to search for the saved password entry in your login keychain (Open Keychain Access.app) and delete it.

comment:3 Changed on Nov 27, 2017 at 2:09:52 PM by mrpooh

Thanks.

I think the problem had something to do with Keychain.

I migrated my previous iMac computer running OSX 10.8.5 (Mountain Lion) to this current iMac (running Sierra) and Keychain wasn't behaving properly, in that it wasn't allowing me access to view some of my own passwords.

For some reason (perhaps taking certain steps in a certain order, and multiple restarts), it seems to be working now !

Cheers!

Note: See TracTickets for help on using tickets.
swiss made software