Cyberduck Mountain Duck CLI

Opened 12 months ago

Closed 12 days ago

#10130 closed defect (worksforme)

Failure authenticating with password protected ed25519 private key

Reported by: kinglok Owned by: dkocher
Priority: normal Milestone: 6.7.0
Component: sftp Version: Nightly Build
Severity: normal Keywords: ed25519
Cc: Architecture: Intel
Platform: macOS 10.12

Description

Cyberduck can log myself through SFTP protocol with using ed25519 private key. However, if a ed25519 key is password-protected, Cyberduck cannot login the same server but showing the following error message:

Exhausted available authentication methods. Please contact your web hosting service provider for assistance.

Attachments (2)

debug.log (48.0 KB) - added by kinglok 4 months ago.
Debug log
sshd_debug.txt (5.1 KB) - added by kinglok 3 months ago.
openssh server debug log.

Download all attachments as: .zip

Change History (34)

comment:1 Changed 12 months ago by dkocher

Please update to the latest snapshot build available which should resolve this issue.

comment:2 Changed 12 months ago by kinglok

I am sorry to tell the problem still exist in version 6.3.0 (26995)

comment:3 Changed 12 months ago by dkocher

  • Component changed from core to sftp
  • Owner set to dkocher
  • Summary changed from Private Key Problem to Failure authenticating with password protected ed25519 private key

comment:4 Changed 8 months ago by UniverseX

Hi, Are you planning to apply this to the stable version (Mac App Store version)? Thanks.

Last edited 8 months ago by UniverseX (previous) (diff)

comment:5 Changed 5 months ago by dkocher

  • Milestone set to 7.0
  • Status changed from new to assigned

comment:6 Changed 5 months ago by dkocher

  • Milestone changed from 7.0 to 6.6.2
  • Resolution set to fixed
  • Status changed from assigned to closed

In r44505.

comment:7 Changed 5 months ago by UniverseX

  • Architecture set to Intel
  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi, Updated the App (via App Store) and unfortunately, it still not working. Getting the following error: "Exhausted available authentication methods. Unknown key type ssh-ed25519. Please contact your web hosting service provider for assistance." However, it seems working fine with the nightly builds. Thanks.

comment:8 follow-up: Changed 5 months ago by dkocher

Are you running version 6.6.2 (28219) from the Mac App Store?

comment:9 in reply to: ↑ 8 ; follow-up: Changed 5 months ago by UniverseX

Replying to dkocher:

Are you running version 6.6.2 (28219) from the Mac App Store?

Correct

comment:10 in reply to: ↑ 9 ; follow-up: Changed 4 months ago by dkocher

Replying to UniverseX:

Replying to dkocher:

Are you running version 6.6.2 (28219) from the Mac App Store?

Correct

I am unable to reproduce with a key generated using ssh-keygen -t ed25519 running 6.6.2 (28219).

comment:11 Changed 4 months ago by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:12 Changed 4 months ago by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:13 follow-up: Changed 4 months ago by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:14 in reply to: ↑ 10 Changed 4 months ago by UniverseX

Replying to dkocher:

Replying to UniverseX:

Replying to dkocher:

Are you running version 6.6.2 (28219) from the Mac App Store?

Correct

I am unable to reproduce with a key generated using ssh-keygen -t ed25519 running 6.6.2 (28219).

I’ve generated it in Putty (Windows).

comment:15 in reply to: ↑ 13 Changed 4 months ago by UniverseX

Replying to dkocher: Then how you explain that it works fine in nightly built? The key is working fine in other Windows/macOS applications (e.g. Yummy FTP Pro, Putty etc.)

comment:16 Changed 4 months ago by dkocher

  • Milestone changed from 6.6.2 to 6.7.0
  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:17 Changed 4 months ago by UniverseX

I have recreated a key via macOS terminal and can confirm that it’s working now. It seems that there is an issue with Putty keys. Thanks.

comment:18 follow-up: Changed 4 months ago by dkocher

Can you please try re-selecting the PuTTY private key in the bookmark settings and try to connect again.

comment:19 in reply to: ↑ 18 Changed 4 months ago by UniverseX

Replying to dkocher:

Can you please try re-selecting the PuTTY private key in the bookmark settings and try to connect again.

I've tried all possible scenarios - reinstalling the app, re-creating bookmarks, re-choosing the key, however, unfortunately, it's still not working. Gonna stick to the newly created key (via ssh-keygen), was able to convert the new key to the Putty format using puttygen nightly build. Thanks.

comment:20 Changed 4 months ago by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:21 Changed 4 months ago by kinglok

  • Version changed from 6.2.10 to Nightly Build

Hi,

I use the following the command to create the private/public key pair for logging my Debian server.

ssh-keygen -t ed25519 -f ssh_host_ed25519_key

While using the latest snapshot of Cyberduck and come across with “Application error”.

please advise how I can help by fixing it up.

Thanks,

Kinglok, Fong

comment:22 Changed 4 months ago by dkocher

Can you please attach the screenshot of the failure message and any related output in the system.log(/Applications/Utilities/Console.app).

comment:23 follow-up: Changed 4 months ago by kinglok

I am using the latest snapshot of Cyberduck.

The screen shows "Unknown application error" and I have attached the log file.

Last edited 4 months ago by kinglok (previous) (diff)

Changed 4 months ago by kinglok

Debug log

comment:24 Changed 4 months ago by dkocher

Jul 21 21:03:29 Moon Cyberduck[2531]: [background-8] WARN  ch.cyberduck.core.threading.BackgroundCallable - Failure running background task Unknown
264	       
265	        java.lang.Exception
266	                at ch.cyberduck.core.threading.BackgroundCallable.<init>(BackgroundCallable.java:38)
267	                at ch.cyberduck.core.threading.DefaultBackgroundExecutor.execute(DefaultBackgroundExecutor.java:66)
268	                at ch.cyberduck.core.AbstractController.background(AbstractController.java:78)
269	                at ch.cyberduck.ui.cocoa.controller.BrowserController$27.run(BrowserController.java:3052)
270	                at ch.cyberduck.ui.cocoa.controller.BrowserController$30.run(BrowserController.java:3172)
271	                at ch.cyberduck.ui.cocoa.controller.BrowserController.disconnect(BrowserController.java:3196)
272	                at ch.cyberduck.ui.cocoa.controller.BrowserController.doUnmount(BrowserController.java:3159)
273	                at ch.cyberduck.ui.cocoa.controller.BrowserController.unmount(BrowserController.java:3150)
274	                at ch.cyberduck.ui.cocoa.controller.BrowserController.unmount(BrowserController.java:3105)
275	                at ch.cyberduck.ui.cocoa.controller.BrowserController.mount(BrowserController.java:3047)
276	                at ch.cyberduck.ui.cocoa.controller.BrowserController.connectBookmarkButtonClicked(BrowserController.java:1801)
277	                at ch.cyberduck.ui.cocoa.controller.BrowserController$11.tableRowDoubleClicked(BrowserController.java:1534)
278	                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
279	                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
280	                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
281	                at java.lang.reflect.Method.invoke(Method.java:498)
282	                at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:171)
283	                at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:53)
284	                at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:83)
285	                at sun.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)
286	                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
287	                at java.lang.reflect.Method.invoke(Method.java:498)
288	                at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:485)
289	                at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:515)
290	                at com.sun.jna.Native.invokeVoid(Native Method)
291	                at com.sun.jna.Function.invoke(Function.java:374)
292	                at com.sun.jna.Function.invoke(Function.java:323)
293	                at com.sun.jna.Function.invoke(Function.java:275)
294	                at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
295	                at com.sun.jna.Library$Handler.invoke(Library.java:234)
296	                at com.sun.proxy.$Proxy0.syntheticSendMessage(Unknown Source)
297	                at org.rococoa.Foundation.send(Foundation.java:209)
298	                at org.rococoa.Foundation.send(Foundation.java:195)
299	                at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:270)
300	                at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:233)
301	                at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:192)
302	                at ch.cyberduck.binding.application.NSApplication$$ByRococoa.run(<generated>)
303	                at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:116)
304	        Caused by: java.lang.NullPointerException
305	                at ch.cyberduck.core.sftp.SFTPExceptionMappingService.map(SFTPExceptionMappingService.java:54)
306	                at ch.cyberduck.core.sftp.SFTPExceptionMappingService.map(SFTPExceptionMappingService.java:45)
307	                at ch.cyberduck.core.AbstractExceptionMappingService.map(AbstractExceptionMappingService.java:42)
308	                at ch.cyberduck.core.sftp.SFTPSession.login(SFTPSession.java:268)
309	                at ch.cyberduck.core.KeychainLoginService.authenticate(KeychainLoginService.java:134)
310	                at ch.cyberduck.core.LoginConnectionService.authenticate(LoginConnectionService.java:165)
311	                at ch.cyberduck.core.LoginConnectionService.connect(LoginConnectionService.java:155)
312	                at ch.cyberduck.core.LoginConnectionService.check(LoginConnectionService.java:102)
313	                at ch.cyberduck.core.pool.StatelessSessionPool.borrow(StatelessSessionPool.java:59)
314	                at ch.cyberduck.core.threading.SessionBackgroundAction.run(SessionBackgroundAction.java:119)
315	                at ch.cyberduck.core.threading.SessionBackgroundAction$1.call(SessionBackgroundAction.java:104)
316	                at ch.cyberduck.core.threading.DefaultRetryCallable.call(DefaultRetryCallable.java:48)
317	                at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:106)
318	                at ch.cyberduck.core.threading.BackgroundCallable.run(BackgroundCallable.java:102)
319	                at ch.cyberduck.core.threading.BackgroundCallable.call(BackgroundCallable.java:61)
320	                at java.util.concurrent.FutureTask.run(FutureTask.java:266)
321	                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
322	                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
323	                at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
324	                at java.lang.Thread.run(Thread.java:748)

comment:25 Changed 4 months ago by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:26 in reply to: ↑ 23 Changed 4 months ago by dkocher

Replying to kinglok:

I am using the latest snapshot of Cyberduck.

The screen shows "Unknown application error" and I have attached the log file.

The error log suggests that the server is dropping the connection while trying to authenticate. Please check the server log for possible reasons.

comment:27 Changed 4 months ago by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Fix for null pointer on disconnect in r44693.

Changed 3 months ago by kinglok

openssh server debug log.

comment:28 Changed 3 months ago by kinglok

Things are getting better but this time produce another type of error: Connection failed Login failed. The connection attempt was rejected. The server may be down, or your network may not be properly configured.

I have attached the server-side log for your comment.

comment:29 Changed 3 months ago by kinglok

  • Resolution fixed deleted
  • Status changed from closed to reopened

Any news?

comment:30 Changed 7 weeks ago by camdenorrb

  • Keywords ed25519 added

Also getting this same issue on Windows 8.1... Anything we can do to fix this?

comment:31 Changed 3 weeks ago by Roy-Orbison

I had the same issue in Windows using a .ppk PuTTY key, but I was able work around it by opening it up in PuTTYgen, then choosing Conversions > Export OpenSSH key (force new file format) from the menu, saving it with a .pem extension, then using that in Cyberduck.

comment:32 Changed 12 days ago by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software