Cyberduck Mountain Duck CLI

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#10151 closed defect (fixed)

Signed links incorrectly URL-encoded

Reported by: tjcelaya Owned by: tjcelaya
Priority: normal Milestone: 6.3.2
Component: triton Version: 6.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Jussi Sallinen reports that generating signed URLs for objects with spaces in the path results in the following error when visiting the URL:

{
"code": "InvalidSignature",
"message": "The signature we calculated does not match the one you sent"
}

I can confirm this is failing in Cyberduck as well (any URL encoding of the object's path causes the issue, including parent directories). Some initial investigation seems to point to the issue being in java-manta, not the Cyberduck codebase. Will update this ticket with a link to the java-manta ticket once that issue is resolved.

(note: this is marked "core" since there is no manta/triton component in the bug tracker)

Change History (5)

comment:1 Changed 11 months ago by dkocher

  • Component changed from core to triton

comment:2 Changed 11 months ago by dkocher

  • Summary changed from Triton: Signed links incorrectly URL-encoded to Signed links incorrectly URL-encoded

I also had a look and it looks like the API should take care of URL encoding using MantaUtils#formatPath and we should pass the unencoded path to getAsSignedURI as what is currently the case.

comment:3 Changed 11 months ago by tjcelaya

  • Status changed from new to assigned

https://github.com/joyent/java-manta/pull/380 has been merged, I'll close this ticket once 3.2.1 is released.

comment:4 Changed 11 months ago by dkocher

  • Milestone set to 7.0
  • Resolution set to fixed
  • Status changed from assigned to closed

In r43516.

comment:5 Changed 11 months ago by dkocher

  • Milestone changed from 7.0 to 6.3.2
Note: See TracTickets for help on using tickets.
swiss made software