Cyberduck Mountain Duck CLI

#10163 closed defect (worksforme)

Passwords for private key not saved or read from keychain

Reported by: johnegg12 Owned by: dkocher
Priority: normal Milestone: 6.7.0
Component: sftp Version: 6.3.1
Severity: normal Keywords: Keychain, passwords
Cc: Architecture: Intel
Platform: Mac OS X 10.5

Description

Hi guys

Ever since latest update every time I click on a historic connection it asks me for password each time. I have select "keychain" in settings but it still doesnt remeber them

John

Attachments (1)

screenshot.png (109.1 KB) - added by czechxteam on Jun 19, 2018 at 7:03:13 AM.

Download all attachments as: .zip

Change History (8)

comment:1 Changed on Dec 6, 2017 at 10:27:22 AM by dkocher

  • Owner set to dkocher
  • Priority changed from highest to normal
  • Severity changed from major to normal

comment:2 Changed on Dec 6, 2017 at 10:29:53 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the issue. Both opening a connection from a bookmark or from a recent item in the history tab will read the previously saved password from the keychain. Please provide exact steps to reproduce the issue and verify if the password entered can be found in your login keychain (Open Keychain Access.app)

comment:3 Changed on Dec 6, 2017 at 10:36:57 AM by dkocher

  • Milestone set to 7.0
  • Summary changed from Passwords not saving to Passwords not saved or read from keychain

Changed on Jun 19, 2018 at 7:03:13 AM by czechxteam

comment:4 Changed on Jun 19, 2018 at 7:05:23 AM by czechxteam

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This bug occur when you use SFTP certificate-based login, but does not occur when you use standard password login.

comment:5 Changed on Jul 9, 2018 at 7:08:14 PM by dkocher

  • Component changed from core to sftp
  • Milestone changed from 7.0 to 6.7.0
  • Summary changed from Passwords not saved or read from keychain to Passwords for private key not saved or read from keychain

comment:6 Changed on Jul 9, 2018 at 7:11:00 PM by dkocher

I cannot reproduce this issue with a password protected private key.

comment:7 Changed on Jul 13, 2018 at 7:46:12 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software