Cyberduck Mountain Duck CLI

#10180 closed defect (fixed)

Modification date on files not preserved

Reported by: ibleedbinari Owned by:
Priority: normal Milestone: 6.3.3
Component: webdav Version: 6.3.1
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 10

Description

In Mountain Duck 2.2.1 and Cyberduck 6.3.1, timestamps are still not being applied with Cryptomator WebDAV mounts. If I mount a Cryptomator WebDAV URL in Mountain Duck, any copied file displays the correct modification date on the share until it is dismounted. After the share is dismounted (or if you view it from the Cryptomator mount point), the timestamp reverts to showing when it was added to the folder rather than the date modified. It is never correct in Cyberduck, even with "preserve modification timestamp" checked. Fairly certain this issue is not on Cryptomator's end since it works as intended with the Cryptomator mount point.

Change History (6)

comment:1 Changed on Dec 15, 2017 at 4:58:55 PM by ibleedbinari

  • Platform set to Windows 10

comment:2 Changed on Dec 28, 2017 at 9:58:23 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

This is caused by a missing feature in WebDAV to perserve timestamps. We do set a DAV:lastmodified property on files uploaded when you have selected "Preserve modification dates" for uploads, but this extension is not supported by most servers.

comment:3 Changed on Dec 28, 2017 at 9:58:41 PM by dkocher

  • Summary changed from Cryptomator WebDAV Timestamps to Modification date on files not preserved

comment:4 Changed on Jan 2, 2018 at 8:59:08 PM by dkocher

  • Milestone set to 7.0
  • Resolution thirdparty deleted
  • Status changed from closed to reopened

comment:5 Changed on Jan 5, 2018 at 3:36:21 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r43615.

comment:6 Changed on Jan 9, 2018 at 2:36:38 PM by dkocher

  • Milestone changed from 7.0 to 6.3.3
Note: See TracTickets for help on using tickets.
swiss made software