Cyberduck Mountain Duck CLI

#10206 closed defect (worksforme)

Out of memory error when downloading large file

Reported by: balupton Owned by: dkocher
Priority: normal Milestone: 6.7.0
Component: b2 Version: 6.4.6
Severity: major Keywords:
Cc: Architecture: Intel
Platform:

Description

I had uploaded an 82GB sparsebundle to Backblaze B2 over 3 days. Once done, I then proceeded to download it to verify it had completed successfully. From memory I quit the app in-between, but I could be wrong.

I left that running for the day or so, for it to get 64.29GB through the download, before my operating system complained it ran out of memory, as well as disk space (despite having 130GB or so available at the time of the download). I opened activity monitor at it turns out that Cybderduck was taking up 77GB of memory, so that is a large swap file it would have had (I only have 16GB of memory).

Screenshot of the situation attached, as well as of the disk space error.

I ended up quitting cybderduck and restarting the computer. I tried to resume the transfer, however I then got a permissions error, screenshot attached.

Attachments (4)

Screen Shot 2018-01-25 at 11.02.35 pm.png (1.1 MB) - added by balupton on Jan 25, 2018 at 3:33:21 PM.
screenshot of the situation
Screen Shot 2018-01-25 at 11.03.47 pm.png (119.8 KB) - added by balupton on Jan 25, 2018 at 3:33:44 PM.
screenshot of the out of disk space error
Screen Shot 2018-01-25 at 11.25.02 pm.png (215.8 KB) - added by balupton on Jan 25, 2018 at 3:35:14 PM.
screenshot of the permission error upon resume
Screen Shot 2018-04-17 at 11.02.23 am.png (5.3 MB) - added by balupton on Apr 17, 2018 at 9:05:39 PM.
Version 6.4.6 (27773)

Change History (14)

Changed on Jan 25, 2018 at 3:33:21 PM by balupton

screenshot of the situation

Changed on Jan 25, 2018 at 3:33:44 PM by balupton

screenshot of the out of disk space error

Changed on Jan 25, 2018 at 3:35:14 PM by balupton

screenshot of the permission error upon resume

comment:1 Changed on Jan 29, 2018 at 8:38:09 PM by dkocher

  • Milestone set to 6.3.6
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from Cyberduck seems to store the file it is downloading from B2 in memory, leading to out of memory exceptions to Seems to store the file it is downloading from B2 in memory, leading to out of memory exceptions

comment:2 Changed on Feb 2, 2018 at 7:12:09 PM by dkocher

  • Milestone changed from 6.3.6 to 6.4.0

Milestone renamed

comment:3 Changed on Feb 2, 2018 at 9:25:26 PM by dkocher

  • Component changed from core to b2
  • Summary changed from Seems to store the file it is downloading from B2 in memory, leading to out of memory exceptions to Seems to store the file it is downloading in memory, leading to out of memory exceptions

comment:4 Changed on Feb 2, 2018 at 9:47:40 PM by dkocher

I cannot reproduce the issue. Downloading some GBs the memory usage of Cyberduck is always below 500MB.

comment:5 Changed on Feb 2, 2018 at 10:18:48 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:6 Changed on Feb 3, 2018 at 2:05:31 AM by balupton

I will attempt to reproduce the error and report back my results. If I can reproduce the error, how would you like to proceed? Happy to arrange a time for you to remote into my machine to debug.

Changed on Apr 17, 2018 at 9:05:39 PM by balupton

Version 6.4.6 (27773)

comment:7 Changed on Apr 17, 2018 at 9:06:34 PM by balupton

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 6.3.4 to 6.4.6

I tried again to download a large file, and it occurred again. Cyberduck Version 6.4.6 (27773). MacOS 10.13.4 (17E199).

Screenshot: https://trac.cyberduck.io/attachment/ticket/10206/Screen%20Shot%202018-04-17%20at%2011.02.23%20am.png

comment:8 Changed on Jul 11, 2018 at 8:05:13 AM by dkocher

  • Milestone changed from 6.4.0 to 6.7.0
  • Summary changed from Seems to store the file it is downloading in memory, leading to out of memory exceptions to Out of memory error when downloading large file

comment:9 Changed on Jul 19, 2018 at 10:25:20 AM by yla

I tried to replicate the issue with 6.6.2 and downloading a 12GB sparsebundle from B2. The memory consumption was in the normal range. Is there any chance to try again with version 6.6.2? Thanks.

comment:10 Changed on Jul 24, 2018 at 7:52:28 AM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software