Cyberduck Mountain Duck CLI

#10238 closed defect (duplicate)

Unable to access SFTP after latest update 6.4.1

Reported by: awgawg Owned by:
Priority: high Milestone: 6.4.3
Component: appstore Version: 6.4.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: macOS 10.13

Description

Since today's update to v6.4.1 I can no longer log on to my 1and1 SFTP accounts. I have verified the settings and tried to turn off the my Norton Security Firewall without success. I have also change the access password with no joy. I just get the Connection failed message (operation not permitted connect failed). It worked as recently as yesterday.

I can download files from the server via HTTP and access the files via Dreamweaver.

Change History (6)

comment:1 Changed on Feb 25, 2018 at 10:35:58 AM by dkocher

  • Milestone set to 6.4.2
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #10237. We can reproduce this issue – thanks for notifying us about this severe issue. It looks like the codesigning security entitlements are not properly applied by the Mac App Store download. We are in contact with Apple Developer Support to get a resolution as soon as possible.

comment:2 Changed on Feb 25, 2018 at 10:36:17 AM by dkocher

  • Component changed from core to appstore

comment:3 Changed on Feb 27, 2018 at 10:07:44 AM by awgawg

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I have installed the ‘fix’ 6.4.2 and there is still a problem connecting to my SFTP server using Cyberduck. I am still the Connection Failed message.

There is the strange entry that when I enter the server name it does not appear against the URL (sftp://{server}) entry. Instead the username incorrectly appears in this line (sftp://{username}) .

I would attach a screenshot but Cyberduck is not working.

comment:4 Changed on Feb 27, 2018 at 11:29:21 AM by dkocher

  • Resolution set to duplicate
  • Status changed from reopened to closed

We are aware of the issue is not resolved yet.

comment:5 Changed on Feb 27, 2018 at 7:08:47 PM by dkocher

  • Milestone changed from 6.4.2 to 6.4.3

Milestone renamed

comment:6 Changed on Feb 27, 2018 at 8:42:51 PM by dkocher

Version 6.4.3 is now available in the Mac App Store fixing the issue with “connect failed” errors when attempting to connect due to missing codesigning entitlements. Unfortunately, this was caused by a bug in the Mac App Store processing and signing of application submissions.

Note: See TracTickets for help on using tickets.