Cyberduck Mountain Duck CLI

#10239 closed defect (fixed)

I updated Cyberduck and can no longer connect to my S3 bucket...

Reported by: csweet Owned by:
Priority: high Milestone: 6.4.3
Component: appstore Version: 6.4.1
Severity: normal Keywords: connectivity
Cc: Architecture: Intel
Platform: macOS 10.13

Description

When I try and connect to S3 bucket I get the following error:

Listing directory mpbn failed. Connect to pbs-ingest.s3.amazonaws.com:443 [pbs-ingest.s3.amazonaws.com/52.216.162.171] failed: Operation not permitted (connect failed). The connection attempt was rejected. The server may be down, or your network may not be properly configured.

In fact I can no longer connect to any directories at all using Cyberduck. I looked at my network settings and nothing jumped out at me but I'm not super literate with TCP/IP issues.

I've tried removing and readding the bookmark/connection and it still doesn't allow me to connect.

One thing that may or may not be a symptom is that while I can enter my Amazon Access Key...I do not get a prompt to enter my Amazon Secret Key.

Hopefully my issue is a common known issue that might have a quick/easy fix someone can share with me.

Thanks!

Chris

Attachments (2)

Screenshot 2018-02-24 13.24.16.jpg (80.9 KB) - added by csweet on Feb 24, 2018 at 6:30:15 PM.
Error Message
Screenshot 2018-02-24 13.27.58.jpg (145.8 KB) - added by csweet on Feb 24, 2018 at 6:31:31 PM.
S3 Connection Config

Download all attachments as: .zip

Change History (6)

Changed on Feb 24, 2018 at 6:30:15 PM by csweet

Error Message

Changed on Feb 24, 2018 at 6:31:31 PM by csweet

S3 Connection Config

comment:1 Changed on Feb 24, 2018 at 6:56:29 PM by csweet

  • Resolution set to fixed
  • Status changed from new to closed

I rendownloaded the app from https://cyberduck.io using the '''Download''' Cyberduck for Mac. link. I opened this install of the app (identical version to the app already on my machine) and tried my existing S3 bookmark and voila! Alls good.

comment:2 Changed on Feb 25, 2018 at 10:36:07 AM by dkocher

  • Milestone set to 6.4.2

Duplicate for #10237. We can reproduce this issue – thanks for notifying us about this severe issue. It looks like the codesigning security entitlements are not properly applied by the Mac App Store download. We are in contact with Apple Developer Support to get a resolution as soon as possible.

comment:3 Changed on Feb 25, 2018 at 10:36:13 AM by dkocher

  • Component changed from core to appstore

comment:4 Changed on Feb 27, 2018 at 7:08:47 PM by dkocher

  • Milestone changed from 6.4.2 to 6.4.3

Milestone renamed

Note: See TracTickets for help on using tickets.
swiss made software