Cyberduck Mountain Duck CLI

Opened 7 months ago

Closed 7 months ago

Last modified 6 months ago

#10240 closed defect (fixed)

550 /players/amish: Permission denied

Reported by: miedward Owned by: dkocher
Priority: normal Milestone: 6.4.4
Component: ftp Version: 6.4.1
Severity: normal Keywords: passive
Cc: Architecture: Intel
Platform: macOS 10.13

Description

I use an ftp site which apparently requires passive mode. I never even knew this because it is apparently the mac default. So recently (around feb 15 or so?) I log in to upload a file and it just starts throwing 500 errors anytime I try to do anything.

cd /players/amish

550 /players/amish: Permission denied. Please contact your web hosting service provider for assistance.

Eventually I downloaded command line ftp, opened a connection, told it to use PASS mode and did a "cd amish" and it worked fine. So something in a recent high sierra patch appears to be messing around with how cyberduck interacts with the mac os settings.

When I was watching the logs I did see some messages about "sandbox" blocking connections to some port, but I can't reproduce that so I am not sure if it is related.

Change History (6)

comment:1 Changed 7 months ago by dkocher

  • Milestone set to 7.0

Please post the transcript from the log drawer (⌘-L).

comment:2 Changed 7 months ago by dkocher

  • Summary changed from FTP doesn't honor passive mode to 550 /players/amish: Permission denied

comment:3 Changed 7 months ago by dkocher

  • Milestone changed from 7.0 to 6.4.4

comment:4 Changed 7 months ago by dkocher

  • Owner set to dkocher
  • Status changed from new to assigned

comment:5 Changed 7 months ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r43954.

comment:6 Changed 6 months ago by dkocher

#10272 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software