Cyberduck Mountain Duck CLI

#10245 closed enhancement (fixed)

Configuration option for the part size when copying large objects

Reported by: jamshid Owned by: dkocher
Priority: normal Milestone: 6.4.4
Component: s3 Version: 6.4.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: macOS 10.13

Description (last modified by dkocher)

Renaming of large (>5GB) objects works with S3 / S3-compatible since #9983 was implemented to use multipart, where each part is a server-side copy of the original stream.

The problem is that this does a 5GB part copy. Since that's such a large copy that can timeout the request. I'm getting that with an S3-compatible system.

Is there any way you can lower that part size, or make it configurable?

Change History (5)

comment:1 Changed on Mar 1, 2018 at 9:39:35 PM by dkocher

  • Milestone set to 7.0
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from Configuration option for the part size when copying large S3 objects to Configuration option for the part size when copying large objects
  • Type changed from defect to enhancement

comment:2 Changed on Mar 1, 2018 at 9:39:57 PM by dkocher

  • Description modified (diff)

comment:3 Changed on Mar 1, 2018 at 9:41:04 PM by dkocher

You can set the hidden configuration option s3.copy.multipart.size. Refer to Hidden configuration options.

comment:4 Changed on Mar 2, 2018 at 10:17:54 AM by dkocher

  • Milestone changed from 7.0 to 6.4.4

comment:5 Changed on Mar 2, 2018 at 4:06:34 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r43957.

Note: See TracTickets for help on using tickets.
swiss made software