Cyberduck Mountain Duck CLI

#10292 closed defect (worksforme)

Server hostname changes resulting DNS failure

Reported by: ilker Owned by: dkocher
Priority: normal Milestone: 7.0
Component: s3 Version: 6.4.4
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 10

Description (last modified by dkocher)

Running Cyberduck on Windows for an S3 compatible endpoint results in DNS failure. Debugging the problem indicates that the connected server is different than the specificed server in configuration. Oddly, this problem does not happen on Mac.

See below screenshot:

https://www.ilkertemir.com/cyberduck_windows.png

Note that configured server is ilkertemir.compat.objectstorage.us-ashburn-1.oraclecloud.com but popup specifies ilkertemir.compat.objectstorage.s3-us-ashburn-1.oraclecloud.com as attempted server (not clear where s3- comes from, this does not happen on Mac).

This example uses the following configuration file: https://svn.cyberduck.io/trunk/profiles/OCI%20Object%20Storage%20(us-ashburn-1).cyberduckprofile

Change History (10)

comment:1 Changed on Mar 30, 2018 at 9:26:06 PM by ilker

  • Description modified (diff)

comment:2 Changed on Mar 30, 2018 at 9:47:00 PM by ilker

  • Summary changed from Cyberduck Windows version tweaks server string to Cyberduck Windows version changes server string resulting DNS failure

comment:3 Changed on Mar 30, 2018 at 9:55:07 PM by dkocher

  • Component changed from core to s3
  • Owner set to dkocher
  • Platform set to Windows 10

comment:4 Changed on Mar 30, 2018 at 9:57:15 PM by dkocher

  • Summary changed from Cyberduck Windows version changes server string resulting DNS failure to Changes server hostname resulting DNS failure

comment:5 Changed on Mar 30, 2018 at 9:57:21 PM by dkocher

  • Milestone set to 6.4.5

comment:6 Changed on Mar 30, 2018 at 10:22:44 PM by ilker

  • Summary changed from Changes server hostname resulting DNS failure to Server hostname changes resulting DNS failure

comment:7 Changed on Apr 2, 2018 at 4:35:53 PM by ilker

It appears that this happens when the region key in the profile is different than what is in the endpoint URL. For instance

  • If the server endpoint is namespace.compat.us-ashburn-1.oraclecloud.com and region is us-ashburn-1, this will problem will not happen.
  • If the server endpoint is namespace.compat.us-phoenix-1.oraclecloud.com and region is us-ashburn-1, this problem will happen.

Problem is persistent across macOS and Windows.

comment:8 Changed on Apr 2, 2018 at 8:47:40 PM by dkocher

  • Milestone 6.4.5 deleted

comment:9 Changed on Sep 4, 2018 at 10:48:00 AM by dkocher

  • Description modified (diff)

comment:10 Changed on Sep 4, 2018 at 11:10:20 AM by dkocher

  • Milestone set to 7.0
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this problem with 6.7.3.

Note: See TracTickets for help on using tickets.
swiss made software