Cyberduck Mountain Duck CLI

#10370 closed defect (fixed)

https Web URL doesnt reflect bookmark setting

Reported by: stefan jacobi Owned by: dkocher
Priority: normal Milestone: 6.9.0
Component: openstack Version: 6.5.0
Severity: normal Keywords: web url https
Cc: Architecture:
Platform:

Description (last modified by dkocher)

The context menu's Web https URL doesn't reflect the setting made in the bookmark any more. The behaviour was introduced with the fix of ticket #10314. Profile is Swift Openstack with Region. It seems the https entry shows some sort of internal server URL.

Last working on 6.4.6.27773 with http context menu entrie. It would show whatever was put into the bookmark' web url field first while the https entry was wrong then, too.

Change History (5)

comment:1 Changed on Jun 25, 2018 at 2:28:10 PM by dkocher

  • Component changed from core to openstack
  • Description modified (diff)
  • Milestone set to 7.0
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Aug 6, 2018 at 3:52:37 PM by dkocher

  • Milestone changed from 7.0 to 6.7.0
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed on Nov 14, 2018 at 2:41:59 PM by stefan jacobi

  • Resolution fixed deleted
  • Status changed from closed to reopened

The issue is still present with >= 6.70 (6.83). The fix isn't listed in the change log.

comment:4 Changed on Dec 20, 2018 at 8:23:40 AM by dkocher

  • Milestone changed from 6.7.0 to 6.9.0

If the OpenStack service returns a X-Account-Meta-Temp-URL-Key we include temporary signed URLs in the list.

Last edited on Dec 20, 2018 at 8:30:45 AM by dkocher (previous) (diff)

comment:5 Changed on Dec 20, 2018 at 8:30:57 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r45896.

Note: See TracTickets for help on using tickets.
swiss made software