Cyberduck Mountain Duck CLI

#10405 closed defect (fixed)

Slow loading directory listing

Reported by: bronskiy Owned by: dkocher
Priority: normal Milestone: 6.8.1
Component: sftp Version: 6.6.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

if there more than 80 files in one folder then cyberduck become no responsible for long time. for example you could try enter to /etc folder on ubuntu 16 checked same directories with the transmit app and it works great.

Attachments (1)

2018-09-01_07-07-57.png (140.2 KB) - added by bronskiy on Sep 1, 2018 at 4:11:58 AM.

Download all attachments as: .zip

Change History (7)

comment:1 Changed on Aug 21, 2018 at 7:41:58 PM by dkocher

  • Component changed from core to sftp
  • Owner set to dkocher
  • Summary changed from unbelievable slow loading to Slow loading directory listing

Please post the transcript from the log drawer (⌘-L).

Changed on Sep 1, 2018 at 4:11:58 AM by bronskiy

comment:2 Changed on Sep 1, 2018 at 4:14:12 AM by bronskiy

there are not too much data

comment:3 Changed on Sep 4, 2018 at 10:45:24 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the issue. There may be some slow down if you have many symbolic links in a directory as we will have to resolve the file type of the target.

comment:4 Changed on Sep 5, 2018 at 2:52:02 AM by bronskiy

  • Resolution worksforme deleted
  • Status changed from closed to reopened

there is zero symbolic links in a directory and this issue is easy reproduce on any server with FTP or SFTP access. So if for some reason you can't reproduce it then just switch this ticket to another developer. this is big serious problem. do not close it until it will be fixed

comment:5 Changed on Oct 9, 2018 at 6:39:53 PM by dkocher

  • Milestone set to 6.8.1

comment:6 Changed on Oct 9, 2018 at 9:29:46 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Fix in r45230.

Note: See TracTickets for help on using tickets.
swiss made software