Cyberduck Mountain Duck CLI

#10447 reopened feature

No package for Raspberry Pi (ARM)

Reported by: Sky_Paladin Owned by:
Priority: normal Milestone:
Component: cli Version: 6.7.1
Severity: normal Keywords: Raspberry Pi, update
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Following the instructions given at (https://trac.cyberduck.io/wiki/help/en/howto/cli#DEBPackageRepository) I have installed duck CLI on a Raspberry Pi 3. While attempting to use it to transfer data via webdav, I found the expected usage did not function, and the help option showed many commands were missing or out of date.

I am not sure if this is a duck issue or a Raspberry Pi issue. My suspicion is that version 0.12 is horribly out of date but I cannot find any indication as to what the current version duck should be, and seeing that I cannot select any Linux-style operating systems in the architecture or platform fields suggests it may not longer be supported.

I hope to be corrected.

More details:

$duck --v
duck 0.12
$sudo apt-get install duck
duck is already the newest version (0.12)

Change History (8)

comment:1 Changed on Aug 30, 2018 at 8:14:12 AM by dkocher

  • Component changed from core to cli
  • Resolution set to worksforme
  • Status changed from new to closed

I suspect you have installed another tool named duck. See the output of apt-cache showpkg duck.

Please try sudo apt-get install duck=6.7.1.28683 instead.

comment:2 Changed on Aug 30, 2018 at 11:39:36 PM by Sky_Paladin

Thanks for your prompt response.

Output of apt-cache showpkg duck:

pi@raspberrypi:~ $ apt-cache showpkg duck
Package: duck
Versions: 
0.12 (/var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_main_binary-armhf_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_main_binary-armhf_Packages
                  MD5: acc3095ebf6763c0fb2b1f525dda4b00


Reverse Depends: 
  check-all-the-things,duck
  pkg-perl-tools,duck
  devscripts,duck
Dependencies: 
0.12 - devscripts (0 (null)) dpkg-dev (0 (null)) perl (0 (null)) libfile-which-perl (0 (null)) libmailtools-perl (0 (null)) libnet-dns-perl (0 (null)) libparse-debcontrol-perl (0 (null)) libpath-class-perl (0 (null)) libregexp-common-email-address-perl (0 (null)) libregexp-common-perl (0 (null)) libstring-similarity-perl (0 (null)) libwww-curl-perl (0 (null)) libxml-xpath-perl (0 (null)) libyaml-libyaml-perl (0 (null)) libconfig-simple-perl (0 (null)) libconfig-inifiles-perl (0 (null)) lynx (0 (null)) libparallel-forkmanager-perl (0 (null)) libdomain-publicsuffix-perl (0 (null)) publicsuffix (0 (null)) git (0 (null)) mercurial (0 (null)) subversion (0 (null)) bzr (0 (null)) 
Provides: 
0.12 - 
Reverse Provides: 

It looks like, as you say, 'another tool named duck' specific to the Pi.

However, attempting to install by the version number yields no dice either;

pi@raspberrypi:~ $ sudo apt-get install duck=6.7.1.28683
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '6.7.1.28683' for 'duck' was not found
pi@raspberrypi:~ $ sudo apt-get install duck=6.7.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '6.7.1' for 'duck' was not found

Can you please provide more feedback on installing the correct Deb CLI version?

comment:3 follow-up: Changed on Aug 31, 2018 at 7:36:58 AM by dkocher

Can you confirm you added our repository to your package sources using

echo -e "deb https://s3.amazonaws.com/repo.deb.cyberduck.io stable main" | sudo tee /etc/apt/sources.list.d/cyberduck.list > /dev/null

comment:4 in reply to: ↑ 3 Changed on Sep 2, 2018 at 11:45:47 PM by Sky_Paladin

Replying to dkocher:

Can you confirm you added our repository to your package sources using

echo -e "deb https://s3.amazonaws.com/repo.deb.cyberduck.io stable main" | sudo tee /etc/apt/sources.list.d/cyberduck.list > /dev/null

I can confirm.

Echo to command line shows stable main was added to the cyberduck.list.d, although I did not do this - the installation instructions had me putting the stable main and the stable nightly in sources.list.d. Opening up cyberduck.list shows that this line is the only contents of the file.

I had actually commented the nightly and main builds from sources.list.d because when I ran sudo apt-get install duck

I received warnings saying that these target packages:

main/binary-armhf/Packages
main/binary-all/Packages
main/i18n/Translation-en_AU
main/i18n/Translation-en

Are configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list.d/cyberduck.list:1.

When I run sudo apt-get install duck=6.7.1.28683 with the lines uncommented in /etc/apt/sources.list, there are no warnings - it simply fails with 'E: Version '6.7.1.28683' for 'duck' was not found}}}

Last edited on Sep 2, 2018 at 11:46:46 PM by Sky_Paladin (previous) (diff)

comment:5 Changed on Sep 11, 2018 at 6:51:05 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:6 Changed on Sep 16, 2018 at 8:11:03 PM by dkocher

  • Summary changed from CLI duck stuck at version 0.12 on Raspberry Pi to No package for Raspberry Pi (ARM)

We do not currently provide packages for ARM architecture.

comment:7 Changed on Sep 16, 2018 at 8:11:21 PM by dkocher

  • Type changed from defect to feature

comment:8 Changed on Jan 15, 2019 at 8:53:21 AM by dkocher

  • Description modified (diff)
Note: See TracTickets for help on using tickets.
swiss made software