Cyberduck Mountain Duck CLI

#10475 closed defect (fixed)

Failure running script in Terminal. Not authorized to send Apple events to Terminal.

Reported by: dkocher Owned by: dkocher
Priority: normal Milestone: 6.8.3
Component: core Version: 6.8.0
Severity: normal Keywords:
Cc: Architecture:
Platform: macOS 10.14

Description


Change History (9)

comment:1 Changed on Sep 27, 2018 at 10:10:48 AM by dkocher

  • Platform set to macOS 10.14

comment:2 Changed on Sep 27, 2018 at 10:26:23 AM by dkocher

  • Owner set to dkocher
  • Status changed from new to assigned

comment:3 Changed on Sep 27, 2018 at 10:37:17 AM by dkocher

If you build your app with the 10.14 SDK, the NSAppleEventsUsageDescription key is required. If it is not provided, trying to send an AppleEvent to another, running app will always return error errAEEventNotPermitted (-1743). The key is only optional when using older SDKs.

comment:4 Changed on Sep 27, 2018 at 11:07:19 AM by dkocher

  • Milestone changed from 7.0 to 6.8.1

comment:5 Changed on Sep 30, 2018 at 10:56:01 AM by dkocher

#10480 closed as duplicate.

comment:6 Changed on Sep 30, 2018 at 10:56:24 AM by dkocher

#10474 closed as duplicate.

comment:7 Changed on Oct 1, 2018 at 2:57:57 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r45136.

comment:8 Changed on Oct 21, 2018 at 2:58:23 PM by dkocher

  • Milestone changed from 6.8.1 to 6.8.3
  • Resolution fixed deleted
  • Status changed from closed to reopened

Fails again; possibly a regression caused by r45249.

comment:9 Changed on Oct 21, 2018 at 8:53:45 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r45332.

Note: See TracTickets for help on using tickets.
swiss made software