Cyberduck Mountain Duck CLI

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#10479 closed defect (fixed)

Drag-n-Drop of multiple files crashes the app

Reported by: me2me2 Owned by: dkocher
Priority: normal Milestone: 6.8.1
Component: core Version: 6.8.0
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: macOS 10.14

Description (last modified by dkocher)

How to re-create: on macOS Mojave try to select multiple files and drop them in the finder. The selection itself will let Cyberduck crash. This happens with 6.8.0 as well as 6.8.1

Process:               Cyberduck [56996]
Path:                  /Applications/Cyberduck.app/Contents/MacOS/Cyberduck
Identifier:            Cyberduck
Version:               6.8.1 (28831)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Cyberduck [56996]
User ID:               502

Date/Time:             2018-09-29 09:22:31.409 +0200
OS Version:            Mac OS X 10.14 (18A391)
Report Version:        12
Anonymous UUID:        D2BE5467-D8CF-6374-78DF-C799987C4964


Time Awake Since Boot: 360000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000008
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x8:
--> 
    __TEXT                 0000000108b45000-0000000108b51000 [   48K] r-x/rwx SM=COW  /Applications/Cyberduck.app/Contents/MacOS/Cyberduck

Application Specific Information:
*** Terminating app due to uncaught exception 'NSGenericException', reason: 'There are 7 items on the pasteboard, but 1 drag images. There must be 1 draggingItem per pasteboardItem.'
terminating with uncaught exception of type NSException
abort() called

Application Specific Backtrace 1:
0   CoreFoundation                      0x00007fff339ec571 __exceptionPreprocess + 256
1   libobjc.A.dylib                     0x00007fff5f999efb objc_exception_throw + 48
2   CoreFoundation                      0x00007fff339ec3a3 +[NSException raise:format:] + 193
3   AppKit                              0x00007fff3120442b -[NSDraggingSession(NSInternal) _initWithPasteboard:image:offset:source:] + 247
4   AppKit                              0x00007fff31203e43 -[NSCoreDragManager dragImage:fromWindow:at:offset:event:pasteboard:source:slideBack:] + 1919
5   AppKit                              0x00007fff312036b5 -[NSWindow(NSDrag) dragImage:at:offset:event:pasteboard:source:slideBack:] + 134
6   AppKit                              0x00007fff315b26cb -[NSOutlineView dragImage:at:offset:event:pasteboard:source:slideBack:] + 214
7   AppKit                              0x00007fff317c8d2f -[NSView(NSDrag) dragPromisedFilesOfTypes:fromRect:source:slideBack:event:] + 458
8   libjnidispatch.dylib                0x00000001296f3134 ffi_call_unix64 + 76

Change History (4)

comment:1 Changed 2 months ago by dkocher

  • Description modified (diff)
  • Milestone set to 6.8.1
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed 2 months ago by dkocher

Possibly related to rdar://44135683.

comment:3 Changed 2 months ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r45179.

comment:4 Changed 2 months ago by me2me2

I couldn't reproduce the error in Version 6.8.1 (28876). So it seems to be fixed. Thank you!!

Note: See TracTickets for help on using tickets.
swiss made software