Cyberduck Mountain Duck CLI

#10489 closed enhancement (wontfix)

Timestamps not set for uploaded files

Reported by: justemapoubelle Owned by: dkocher
Priority: normal Milestone: 6.9.0
Component: openstack Version: 6.8.0
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 10

Description

Hello,

When I first tried CyberDuck, i was delighted to see those two commands:Synchronize and keep filestamps. But it does not work at all with OpenStack (Public Cloud storage with OVH). Hence it is impossible to synchronize computers. If you upload a file with CyberDuck or MountainDuck, you will download this very file on the other computers even if the file has not been modified.

As long as it won't be in use, I won't buy a MountainDuck license.

I am sure it's a CyberDuck and MountainDuck problem, because it does not happen when I upload manually a file or using rClone or rClone browser.

If you do not plan to fix this, you should erase those two commands.

Cheers. j

Attachments (2)

Timestamps screenshot 01.png (15.5 KB) - added by justemapoubelle on Nov 3, 2018 at 10:27:30 AM.
Timestamps screenshot 02.png (11.8 KB) - added by justemapoubelle on Nov 3, 2018 at 10:27:40 AM.

Download all attachments as: .zip

Change History (12)

comment:1 Changed on Oct 9, 2018 at 8:20:25 AM by dkocher

  • Component changed from core to openstack
  • Owner set to dkocher
  • Priority changed from high to normal

comment:2 follow-up: Changed on Oct 9, 2018 at 9:58:20 AM by dkocher

Can you confirm you are running version 6.8.0? This is supposed to be fixed (#10446).

comment:3 in reply to: ↑ 2 Changed on Oct 9, 2018 at 8:02:06 PM by justemapoubelle

Replying to dkocher:

Can you confirm you are running version 6.8.0? This is supposed to be fixed (#10446).

Hello,

I confirm using version 6.8.0 (28825). The update returns " Software is up to date " in my native language.

Cheers, j

comment:4 Changed on Nov 2, 2018 at 10:09:43 AM by dkocher

  • Milestone set to 7.0
  • Summary changed from CyberDuck and MountainDuck are modifying file timestamps to Timestamps not set for uploaded files

comment:5 Changed on Nov 2, 2018 at 10:10:45 AM by dkocher

Can you please double check Preserve modification date is set in Preferences → Transfers → Timestamps.

comment:6 follow-up: Changed on Nov 2, 2018 at 10:10:53 AM by dkocher

  • Status changed from new to assigned

Changed on Nov 3, 2018 at 10:27:30 AM by justemapoubelle

Changed on Nov 3, 2018 at 10:27:40 AM by justemapoubelle

comment:7 in reply to: ↑ 6 Changed on Nov 3, 2018 at 10:29:45 AM by justemapoubelle

Replying to dkocher: Hi,

Thks for the follow-up. I was / am using such setting. I am using v 6.8.3 (29107) and the problem is still there (see Timestamps screenshot 01.png and Timestamps screenshot 02.png).

I understand that it should work in v7.0

Have a nice day. j

comment:8 Changed on Dec 21, 2018 at 4:40:47 PM by dkocher

  • Milestone changed from 7.0 to 6.9.0

comment:9 Changed on Dec 21, 2018 at 4:40:54 PM by dkocher

  • Type changed from defect to enhancement

comment:10 Changed on Jan 8, 2019 at 2:17:36 PM by dkocher

  • Resolution set to wontfix
  • Status changed from assigned to closed

OpenStack Swift does not support setting timestamps for files but will always report the server side modification date. We could add a custom property to metadata but this is not feasible for performance reasons as querying the metadata requires another request for every single file in the object listing.

Note: See TracTickets for help on using tickets.
swiss made software