Cyberduck Mountain Duck CLI

#10494 closed defect (fixed)

Failure transferring more than one file

Reported by: Argonaut Owned by: dkocher
Priority: high Milestone: 6.8.2
Component: ftp Version: 6.8.0
Severity: major Keywords:
Cc: Architecture: Intel
Platform: macOS 10.13

Description

I updated from v.6.6.0 to v6.8.1 today (using CyberDuck's built-in updater). Since then, CyberDuck has reported a variety of errors when trying to upload or download more than one file with ftp. The first file works but, the errors are shown when CyberDuck tries the second file and the download ceases. Errors including:

  • Interoperability failure 425 No data connection.
  • Connection failed 425 No data connection.
  • Download [filename] failed. Read timed out. The connection attempt timed out.
  • Interoperability failure 200 TYPE is now 8-bit binary.

This only occurs when trying to transfer more than one file. There seems to be no disconnection and single file transfers work perfectly. I downgraded to v6.6.0 and there have been no such problems. Sorry I can't be more specific about which version introduced the issue – I can't find a way to DL old versions of Cyberduck.

I am using Cyberduck on an Apple Mac Mini (mid 2011) running macOS 10.13.6. The FTP server is on a Topfield 7160 PVR. The connection is over an ethernet cable.

Change History (9)

comment:1 Changed on Oct 13, 2018 at 12:18:29 PM by dinkblam

i can confirm this

comment:2 Changed on Oct 15, 2018 at 7:27:55 PM by dkocher

  • Milestone set to 6.8.2
  • Owner set to dkocher
  • Status changed from new to assigned

comment:3 Changed on Oct 15, 2018 at 8:03:11 PM by dkocher

  • Summary changed from v6.8.1 FTP fails in transferring more than one file to Failure transferring more than one file

comment:4 Changed on Oct 15, 2018 at 8:06:51 PM by dkocher

#10500 closed as duplicate.

comment:5 Changed on Oct 15, 2018 at 8:06:56 PM by dkocher

  • Priority changed from normal to high

comment:6 Changed on Oct 15, 2018 at 8:07:26 PM by dkocher

#10498 closed as duplicate.

comment:7 Changed on Oct 16, 2018 at 6:41:46 AM by dkocher

#10501 closed as duplicate.

comment:8 Changed on Oct 16, 2018 at 6:41:58 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r45246.

comment:9 Changed on Oct 18, 2018 at 9:09:55 AM by dkocher

#10504 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software