Cyberduck Mountain Duck CLI

#10551 closed defect (worksforme)

unzip: cannot find or open

Reported by: chopper Owned by:
Priority: normal Milestone: 6.9.3
Component: sftp Version: 6.8.3
Severity: normal Keywords: unzip
Cc: Architecture:
Platform: Mac OS X 10.11

Description (last modified by dkocher)

Hi, I have connect to a new Cloudways / Digital ocean server. When I try to Zip or Unzip anything, i get the following error: SSH is enabled on server and user. SSH via terminal works using the unzip command...?

Interoperability failure
unzip:  cannot find or open /applications/xjhwthkwpp/public_html/testzip.zip, /applications/xjhwthkwpp/public_html/testzip.zip.zip or /applications/xjhwthkwpp/public_html/testzip.zip.ZIP.. Please contact your web hosting service provider for assistance.

Via Terminal is ok:

[master_hidden]:public_html$ unzip testzip.zip
Archive:  testzip.zip
  inflating: Screen Shot 2018-12-04 at 21.13.51.png  
   creating: __MACOSX/
  inflating: __MACOSX/._Screen Shot 2018-12-04 at 21.13.51.png 

Attachments (2)

Screen Shot 2018-12-05 at 10.46.59.png (115.8 KB) - added by chopper on Dec 5, 2018 at 9:50:21 AM.
Screen Shot 2018-12-05 at 10.51.39.png (17.1 KB) - added by chopper on Dec 5, 2018 at 9:53:54 AM.
COULD IT BE THE INCORRECT PATH IN THE CYBERDUCK FOOTER? "public\_html" SEE ATTACHMENT:

Download all attachments as: .zip

Change History (6)

Changed on Dec 5, 2018 at 9:53:54 AM by chopper

COULD IT BE THE INCORRECT PATH IN THE CYBERDUCK FOOTER? "public\_html" SEE ATTACHMENT:

comment:1 Changed on Dec 27, 2018 at 9:25:46 PM by dkocher

  • Description modified (diff)
  • Priority changed from high to normal
  • Severity changed from major to normal

comment:2 Changed on Feb 14, 2019 at 1:25:02 PM by dkocher

We escape all non alphanumeric characters from the path arguments.

Last edited on Feb 14, 2019 at 1:25:35 PM by dkocher (previous) (diff)

comment:3 Changed on Feb 14, 2019 at 1:26:51 PM by dkocher

  • Milestone set to 6.9.3
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the error with the commandunzip -qn /home/dkocher/public\_html/10\-14\-Night\.jpg\.zip -d /home/dkocher/public\_html on a test server.

comment:4 Changed on Feb 14, 2019 at 1:26:57 PM by dkocher

  • Component changed from core to sftp
Note: See TracTickets for help on using tickets.
swiss made software