Cyberduck Mountain Duck CLI

#10633 closed defect (worksforme)

Synchronize-download and download-compare don't seem to work

Reported by: kristan Owned by:
Priority: normal Milestone:
Component: cli Version: 6.8.0
Severity: normal Keywords:
Cc: Architecture:
Platform: macOS 10.13

Description (last modified by dkocher)

i'm attempting to get just changed/updated files from my ftp site to my machine and can't seem to get it to work, i'm not sure if it's something i'm doing wrong or if these commands don't work (or don't work as i expect).

when initially downloading i'm using:

     --preserve --existing compare --download 
          * (as well as all the other bits like where to get stuff and where to put it) 

if i run the command again duck seems to just re-download everything, no comparing happening (the files on the server aren't changing)

if i attempt to use synchronize with:

--preserve --existing download --synchronize  
 duck seems to look at the files (based on the verbose output) but then returns with 
      Transfer incomplete…
      > QUIT 
      < 221-Goodbye. You uploaded 0 and downloaded 0 kbytes.

this is even when files *have* changed on the server and should thus be new and pulled down (or so i expect)

Can you let me know if i'm missing something in the commands i'm running or in how i'm expecting this to work?

In case it affects things, the ftp path i'm pulling from has quite a few subfolders and files, not just a flat structure.

Change History (4)

comment:1 Changed on Feb 23, 2019 at 10:22:26 PM by kristan

aha. of course right after i make the ticket i learn something new...

If i have a trailing / on the destination things work as i expect.

If i run

duck  --assumeyes --preserve --parallel 7 --existing compare --download ftps://mycoolsite/registration/ ~/Lab/ftp/clean

I get the behavior i described as the first run downloads the files in the registration folder to ~/Lab/ftp/clean

If i run it again though it downloads to ~/Lab/ftp/clean/registration

So a third run works but now I have the same files in /registration/ nested within eachother (in ~/Lab/ftp/clean and ~/Lab/ftp/clean/registration) on my local machine.

It seems as though subsequent runs are also finding additional files to download that aren't different but currently in the neighbourhood of 350 MB instead of 3.5 GB.

Last edited on Dec 12, 2019 at 10:03:29 AM by dkocher (previous) (diff)

comment:2 Changed on Oct 23, 2019 at 2:19:14 PM by dkocher

  • Summary changed from duck cli - synchronize-download and download-compare don't seem to work to Synchronize-download and download-compare don't seem to work

comment:3 Changed on Dec 12, 2019 at 10:02:57 AM by dkocher

  • Description modified (diff)

comment:4 Changed on Dec 12, 2019 at 10:04:00 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software