Cyberduck Mountain Duck CLI

#10634 closed defect (worksforme)

No prompt for authorization when connecting to different account

Reported by: rth10260 Owned by: dkocher
Priority: high Milestone: 7.0
Component: dropbox Version: 6.9.3
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Windows 8.1

Description (last modified by rth10260)

note: similar to closed ticket # 10562

I have two Dropbox accounts A and B. For the first time I use Cyberduck for a connection. I create a connection for account A and get the OAuth string back and can access this account. I disconnect account A.

Now I create a new connection for B and enter the other username (email), then click Connect button.

Error I get directly connected to account A, I never get to see the Dropbox authorization webpages for account B and have no new OAuth string to enter. Cyberduck does not ask for such.


ETA. sorry I cannot remove duplicate PNG files of "rth new profile"

Change History (14)

comment:1 Changed on Feb 24, 2019 at 11:46:20 PM by rth10260

  • Description modified (diff)

comment:2 Changed on Mar 12, 2019 at 8:58:26 AM by dkocher

  • Component changed from core to dropbox
  • Owner set to dkocher
  • Summary changed from Multiple Dropbox accounts, cannot connect except first to No prompt for authorization when connecting to different account

comment:3 follow-up: Changed on Mar 12, 2019 at 9:03:35 AM by dkocher

I cannot reproduce this issue with two bookmarks for Dropbox set to different accounts by distinct username settings.

comment:4 in reply to: ↑ 3 ; follow-up: Changed on Mar 13, 2019 at 1:06:22 PM by rth10260

  • Priority changed from normal to high

Replying to dkocher:

I cannot reproduce this issue with two bookmarks for Dropbox set to different accounts by distinct username settings.

I can now better document this bug - it's for real!

After your reply I tried one more to make a new connection for account "B". To my great surprize the operation proceeded right thru the authorization and completed with seeing the correct Dropbox account.

Using again the New Connection and entering the username to connect to a different Dropbox account I again get that weird redirection to a wrong Dropbox account of listed in the booksmarks (and may have been logged in before in the same Cyberduck session).

It all looks suspiciously like an initialization error, so I exit Cyberduck and relaunch it.Again I perceive the situation as originally described. To note once more, connection attempt are thru the New Connection button, not a bookmark.

A new side effect observed:

I try to make a New Connection to Dropbox using a fake account name (funny-at-nowhere-dot-net). Not unexpectedly I don't get to see any Dropbox interaction for verification. BUT to my surprize Cyberduck offers me an Authorization Code on https://cyberduck.io/oauth/?state=kUg9Vb8l&code=<some-string>, at the same time *not* opening the associated dialog to copy the string into it.

Question: is Cyberduck handling invalid account verifications correctly?

I was wondering what may have been the difference from the time original report and the successful connection following the feedback. Also keeping in mind as what I perceive to be an initialization error. I then remember that Windows DLLs can initialize and retain data between invocations. The Cyberduck installation directory reveals the use of DLLs (no surprize there of course).

My attempt to prove my case: I create a fresh Dropbox account with another available valid username / email address. Then I reboot my Notebook. Run Cyberduck and make a New Connection to this new Dropbox account. Works as intended!

Conclusion: please check Cyberduck components, especially the Dropbox connection stuff, for correct handling of reentry / reinvocation and data retention / initialization.

Regards - Richard

Last edited on Mar 13, 2019 at 1:07:15 PM by rth10260 (previous) (diff)

comment:5 Changed on Mar 13, 2019 at 7:25:10 PM by dkocher

  • Milestone set to 6.9.5
  • Status changed from new to assigned

comment:6 in reply to: ↑ 4 Changed on Mar 17, 2019 at 3:23:15 PM by dkocher

Replying to rth10260: To me it looks like you do not log out the Dropbox account A after attempting to get an authorization code for account B. Before opening the second connection, make sure to log out from your Dropbox account in the web browser, otherwise the authentication code obtained will be linked to the account you originally logged in.

comment:7 Changed on Mar 21, 2019 at 3:22:17 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:8 Changed on Jun 4, 2019 at 2:20:54 PM by dkocher

  • Milestone changed from 6.9.5 to 7.0

Ticket retargeted after milestone deleted

Note: See TracTickets for help on using tickets.
swiss made software