Cyberduck Mountain Duck CLI

#10647 closed defect (fixed)

Existing S3 metadata not visible

Reported by: jabeler Owned by: dkocher
Priority: normal Milestone: 7.0
Component: s3 Version: 6.9.4
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: macOS 10.14

Description

Existing metadata is not visible while browsing S3 files in Cyberduck.

Adding or updating records works, but these changes are not visible in Cyberduck after a refresh.

Attached are screenshots from Cyberduck and the S3 console for the same file.

I'm not sure when this broke, but it was working at some point in the past.

Attachments (2)

Cyberduck.png (175.5 KB) - added by jabeler on Mar 7, 2019 at 6:05:08 PM.
AWS.png (72.9 KB) - added by jabeler on Mar 7, 2019 at 6:05:15 PM.

Download all attachments as: .zip

Change History (11)

Changed on Mar 7, 2019 at 6:05:08 PM by jabeler

Changed on Mar 7, 2019 at 6:05:15 PM by jabeler

comment:1 Changed on Mar 8, 2019 at 8:13:43 AM by dkocher

  • Milestone set to 7.0
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Mar 8, 2019 at 8:53:21 AM by dkocher

I cannot reproduce this error. Can you confirm you are running version 6.9.4.

comment:3 Changed on Mar 8, 2019 at 2:53:00 PM by jabeler

I am running 6.9.4.

I've tried a few older versions as well. It seems to be working as expected in 6.8.3 and earlier, but not working in 6.9 and later.

comment:4 Changed on Mar 8, 2019 at 3:00:10 PM by jabeler

One note, folder metadata appears normally for me in 6.9.4, but file metadata does not.

comment:5 Changed on Mar 9, 2019 at 8:26:08 PM by dkocher

Regression from r45788.

comment:6 Changed on Mar 9, 2019 at 8:26:36 PM by dkocher

  • Milestone changed from 7.0 to 6.9.5

comment:7 Changed on Mar 9, 2019 at 9:55:57 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r46549.

comment:8 Changed on Mar 11, 2019 at 2:06:21 AM by jabeler

Fix confirmed!

Works as expected in the 7.0.0.30235 snapshot build. Thanks!

comment:9 Changed on Jun 4, 2019 at 2:20:54 PM by dkocher

  • Milestone changed from 6.9.5 to 7.0

Ticket retargeted after milestone deleted

Note: See TracTickets for help on using tickets.