Cyberduck Mountain Duck CLI

#1066 closed defect (duplicate)

Some folder names incorrectly appear with one leading white space character

Reported by: charrison Owned by: dkocher
Priority: normal Milestone:
Component: ftp Version: 2.7.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

When connecting to certain servers (AIX 5.2 in my case), some folder names incorrectly appear with one leading white space character. When attempting to change into these folders Cyberduck says "a file or directory in the pathname does not exist". The only way to get into the folder is to select the "Go" menu and choose "Go To Folder" and type in the directory manually. I assume that this is related the some servers incosistently displaying their directory listing output due to some modified timestamps being different lengths - however this bug makes Cyberduck entirely unusable as an FTP client. The bug did not always exist and other FTP clients seem to be able to handle these types of directory listings.

Change History (3)

comment:1 Changed on Mar 13, 2007 at 10:32:02 AM by dkocher

  • Component changed from core to ftp
  • Priority changed from high to normal
  • Severity changed from major to normal

comment:2 Changed on Apr 24, 2007 at 12:28:42 PM by dkocher

What is the response of the server to the SYST command? Is there any way I can get access to this server to debug the issue?

comment:3 Changed on Aug 18, 2007 at 11:32:48 AM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

Possible a duplicate of #143.

Note: See TracTickets for help on using tickets.
swiss made software