Cyberduck Mountain Duck CLI

#10694 closed defect (worksforme)

Failure retrieving auto configuration script

Reported by: julianhinz Owned by:
Priority: normal Milestone:
Component: cli Version: 6.9.4
Severity: major Keywords:
Cc: Architecture:
Platform: macOS 10.14

Description (last modified by julianhinz)

Upon fresh install on MacOS 10.14.4 with homebrew "duck --list ..." (and other options) throws following error, before printing correct output:

2019-05-03 15:43:51.135 duck[2689:92359] Failure retrieving auto configuration script from http://wpad/wpad.dat: Error Domain=NSCocoaErrorDomain Code=260 "The file “wpad.dat” couldn’t be opened because there is no such file." UserInfo={NSURL=http://wpad/wpad.dat, NSUnderlyingError=0x7fec67dd0100 {Error Domain=NSURLErrorDomain Code=-1003 "A server with the specified hostname could not be found." UserInfo={NSUnderlyingError=0x7fec6b01ee80 {Error Domain=kCFErrorDomainCFNetwork Code=-1003 "A server with the specified hostname could not be found." UserInfo={NSErrorFailingURLStringKey=http://wpad/wpad.dat, NSErrorFailingURLKey=http://wpad/wpad.dat, _kCFStreamErrorCodeKey=8, _kCFStreamErrorDomainKey=12, NSLocalizedDescription=A server with the specified hostname could not be found.}}, NSErrorFailingURLStringKey=http://wpad/wpad.dat, NSErrorFailingURLKey=http://wpad/wpad.dat, _kCFStreamErrorDomainKey=12, _kCFStreamErrorCodeKey=8, NSLocalizedDescription=A server with the specified hostname could not be found.

Trying to connect to S3 bucket fails entirely and additionally throws following error:

Connection failed. DNS lookup for my-bucket failed. DNS is the network service that translates a server name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing access to the network.

Any idea what's causing this?

Change History (8)

comment:1 Changed on May 3, 2019 at 2:02:38 PM by julianhinz

  • Description modified (diff)

comment:2 Changed on May 3, 2019 at 2:07:16 PM by dkocher

Please check your proxy settings in System Preferences → Network.

comment:3 Changed on May 3, 2019 at 2:07:27 PM by dkocher

  • Summary changed from duck cli throwing errors, failing for some protocols to Failure retrieving auto configuration script

comment:4 follow-up: Changed on May 3, 2019 at 2:11:41 PM by julianhinz

Not using any proxy, only "Auto Proxy Discovery" ticked.

comment:5 in reply to: ↑ 4 ; follow-up: Changed on May 3, 2019 at 2:24:38 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to julianhinz:

Not using any proxy, only "Auto Proxy Discovery" ticked.

Please uncheck.

comment:6 in reply to: ↑ 5 Changed on May 3, 2019 at 4:12:53 PM by julianhinz

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to dkocher:

Replying to julianhinz:

Not using any proxy, only "Auto Proxy Discovery" ticked.

Please uncheck.

Great, first part of the issue resolved. Second part persists though, I guess it may not be directly related. What could cause this?

Connection failed. DNS lookup for my-bucket failed. DNS is the network service that translates a server name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing access to the network.

Only for S3 (for me at least), Dropbox and OneDrive not showing this.

comment:7 Changed on May 4, 2019 at 10:01:46 AM by julianhinz

One more thing: None of the errors occur when using Cyberduck, only when using the CLI.

comment:8 Changed on May 30, 2019 at 3:15:35 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

Please refer to our documentation on URIs. You should use duck --list s3:/mybucket/ when connecting to Amazon S3.

Note: See TracTickets for help on using tickets.