Cyberduck Mountain Duck CLI

#10697 closed defect (duplicate)

Cyberduck 6.9.4 breaks Swift large object support

Reported by: tzakharko Owned by:
Priority: normal Milestone: 7.0
Component: openstack Version: 6.9.4
Severity: major Keywords: Swift, SLO
Cc: Architecture: Intel
Platform: macOS 10.14

Description

When trying to upload large files to a Swift container, Cyberduck 6.9.4 reports a "file not found" error message (see attachment). Uploads work correctly with 6.9.3. I have only tried it on a Mac, no idea if Windows also has this issue.

Our university's swift storage support engineer has provided the following information:

I was able to see the error message and reproduce it with cyberduck.

What I see from the logs is the the cyberduck client does a "HEAD" request, to see if the (first) segment it is already on the storage which returns a 404 not found and then stops.

When I try to upload a new file - this should have nothing to do with segments on the server part since the segmentation is trasparent to the swift implementation - I see that a HEAD request returning a 404 then the PUT request follow to actually upload the new file.

Attachments (1)

PastedGraphic-1.png (152.7 KB) - added by tzakharko on May 7, 2019 at 9:37:41 AM.

Download all attachments as: .zip

Change History (3)

Changed on May 7, 2019 at 9:37:41 AM by tzakharko

comment:1 Changed on May 7, 2019 at 9:56:58 AM by dkocher

  • Component changed from core to openstack
  • Milestone set to 6.9.5
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #10657.

comment:2 Changed on Jun 4, 2019 at 2:20:54 PM by dkocher

  • Milestone changed from 6.9.5 to 7.0

Ticket retargeted after milestone deleted

Note: See TracTickets for help on using tickets.
swiss made software