Cyberduck Mountain Duck CLI

#10750 closed defect (fixed)

Can't switch into certain encrypted directories

Reported by: rootie Owned by: dkocher
Priority: high Milestone: 7.1
Component: cryptomator Version: 7.0.1
Severity: critical Keywords:
Cc: cryptronius@gmx.de Architecture: Intel
Platform: Windows 10

Description

Hi,

I've experienced an issue with both Cyberduck and Mountain duck in combination with a Cryptomator vault. First of all I've created an offline vault and copied about 350 GB of files into it. Then I've synched the crypted files to my private Microsoft OneDrive (Office 365 Personal account).

When I now try to access the decrypted files through Cyberduck, I get an error message when trying to enter certain directories. Some directories work like a charm, some don't. I can't see any pattern on when it works and when it doesn't.

In Mountain Duck I can double click on those directories but they're shown as empty.

I've downloaded the Cryptomator iOS app and tried to access the vault from there. It works like a charm in this app so it must be an issue with the Cryptomator Plugin in Cyberduck and Mountain Duck.

I've attached the error log.

This doesn't work for both Mac and Windows versions.

Attachments (4)

Error.txt (2.6 KB) - added by rootie on Jun 27, 2019 at 4:20:24 PM.
Error log
Error 2.txt (4.0 KB) - added by rootie on Jun 27, 2019 at 4:22:48 PM.
Error Log 2
Layout.zip (278.1 KB) - added by jmalek on Jul 22, 2019 at 11:27:11 AM.
Vault.zip (446.9 KB) - added by jmalek on Jul 22, 2019 at 11:27:25 AM.
Passphrase: vault

Download all attachments as: .zip

Change History (15)

Changed on Jun 27, 2019 at 4:20:24 PM by rootie

Error log

Changed on Jun 27, 2019 at 4:22:48 PM by rootie

Error Log 2

comment:1 Changed on Jun 27, 2019 at 6:20:41 PM by rootie

  • Priority changed from normal to high

comment:2 Changed on Jul 9, 2019 at 3:59:47 PM by dkocher

  • Owner set to dkocher
  • Status changed from new to assigned

comment:3 Changed on Jul 9, 2019 at 4:01:01 PM by dkocher

We will try to reproduce the issue.

comment:4 Changed on Jul 14, 2019 at 5:39:54 AM by rootie

  • Cc cryptronius@gmx.de added

I now have tried to regenerate the whole Cryptomator vault (390 GB) through Cyberduck using the 'local vault' functionality. After all files were encrypted I moved the crypted vault to the OneDrive directory and let it upload. After the upload has finished I can perfectly browse through the files using the iOS Cryptomator app but now the outermost directory already fails and I can't even reach all my other directories.

The weird thing is that the same vault on the local hard disk worked while the uploaded vault fails. I doubt that the vault has been uploaded incorrectly by the OneDrive app as it works like a charm with the iOS app.

Have you already been able to reproduce this?

Best regards, rootie

Last edited on Jul 14, 2019 at 5:40:11 AM by rootie (previous) (diff)

comment:5 Changed on Jul 17, 2019 at 1:38:21 PM by jmalek

  • Owner changed from dkocher to jmalek
  • Status changed from assigned to new

We can reproduce this issue. It looks like there are some issues with the Cryptomator decryption on OneDrive resulting in directories not being found correctly.

comment:6 Changed on Jul 17, 2019 at 2:58:23 PM by dkocher

  • Summary changed from Can't switch into certain Cryptomator directories with Cyberduck and Mountain Duck to Can't switch into certain encrypted directories

comment:7 Changed on Jul 22, 2019 at 8:29:26 AM by rootie

Is there any ETA for this?

comment:8 Changed on Jul 22, 2019 at 10:43:24 AM by dkocher

We don't have an ETA for this yet.

Changed on Jul 22, 2019 at 11:27:11 AM by jmalek

Changed on Jul 22, 2019 at 11:27:25 AM by jmalek

Passphrase: vault

comment:9 Changed on Aug 7, 2019 at 5:24:53 AM by rootie

Hi,

please update me on when this will be fixed. I have bought the MD license just because of this feature and I am not able to use it at all.

I can help you on testing and give you input on whatever you need.

Please consider priotitizing this as it renders one of your main new features unusable.

comment:10 Changed on Aug 15, 2019 at 1:24:03 PM by dkocher

  • Owner changed from jmalek to dkocher
  • Status changed from new to assigned

comment:11 Changed on Aug 20, 2019 at 10:00:59 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r47535.

Note: See TracTickets for help on using tickets.