Cyberduck Mountain Duck CLI

#10767 closed defect (worksforme)

409 object already exists error for uploads

Reported by: stephenmcconnachie Owned by: dkocher
Priority: normal Milestone: 7.1
Component: spectralogic Version: 7.0.1
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 10

Description

Hi there,

I’ve been trying to get Cyber Duck / Mountain Duck to work with our Spectra Logic Black Pearl but uploads to any bucket fail with the error attached: 409 object already exists. This is 100% reproducible with any files whether or not the file actually exists in the bucket.

It is using my Black Pearl credentials - access key / secret - which work perfectly with Spectra's own Eon Browser, so it’s not a creds issue.

I have also reported this in a ticket to Spectra Logic in case it is not a Cyber Duck but a Black Pearl issue. But I was wondering if this is a known issue you've heard before?

All the best, Stephen McConnachie, British Film Institute, London, UK

Attachments (1)

image001.jpg (63.8 KB) - added by stephenmcconnachie on Jul 30, 2019 at 8:03:36 AM.
Screengrab showing 409 error

Download all attachments as: .zip

Change History (5)

Changed on Jul 30, 2019 at 8:03:36 AM by stephenmcconnachie

Screengrab showing 409 error

comment:1 Changed on Aug 5, 2019 at 2:49:34 PM by dkocher

  • Summary changed from Spectra S3 Black Pearl integration: reproducible error when PUTting files to bucket to 409 object already exists error for uploads

comment:2 Changed on Aug 5, 2019 at 2:49:48 PM by dkocher

  • Owner set to dkocher
  • Status changed from new to assigned

comment:3 Changed on Aug 5, 2019 at 2:58:29 PM by dkocher

  • Milestone set to 7.1

comment:4 Changed on Aug 7, 2019 at 2:39:30 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

We cannot reproduce this with the current snapshot build.

Note: See TracTickets for help on using tickets.