Cyberduck Mountain Duck CLI

#10770 closed defect (duplicate)

Rackspace protocol CLI help has too many slashes

Reported by: softgrow Owned by: jmalek
Priority: normal Milestone: 7.1
Component: cli Version: 6.9.4
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

The CLI help lists the Rackspace Cloud files protocol as

$ duck --help Usage:duck [options...] ... Default protocols ...

Rackspace Cloud Files (US) rackspace://<container>/<key>

...

However the documentation at https://trac.cyberduck.io/wiki/help/en/howto/cli#URI lists the protocol as rackspace:/<container>/<key> (absolute) rackspace:<container>/<key> (relative)

It appears that some time in the last few months prior to 6.9.4, rackspace:// was treated the same as rackspace:/ but this is no longer the case the the URI cannot be specified with two slashes. If it is the <container> item is treated as server address which is non-sensical for the rackspace protocol.

To resolve this bug the help should have the extra slash removed to become:

$ duck --help Usage:duck [options...] ... Default protocols ...

Rackspace Cloud Files (US) rackspace:/<container>/<key>

...

I have examined the source and each protocol is enumerated from lines 59-71 of https://github.com/iterate-ch/cyberduck/blob/master/cli/src/main/java/ch/cyberduck/cli/TerminalHelpPrinter.java

Change History (6)

comment:1 Changed on Aug 2, 2019 at 12:30:27 PM by dkocher

  • Milestone set to 7.1

comment:2 Changed on Aug 5, 2019 at 2:36:23 PM by dkocher

  • Owner set to jmalek

comment:3 Changed on Sep 1, 2019 at 7:56:01 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:4 follow-up: Changed on Sep 1, 2019 at 11:01:44 PM by softgrow

  • Resolution worksforme deleted
  • Status changed from closed to reopened

There is still a conflict between the help and the documentation.

comment:5 in reply to: ↑ 4 Changed on Sep 2, 2019 at 5:54:49 AM by dkocher

Replying to softgrow:

There is still a conflict between the help and the documentation.

What version of Cyberduck CLI are you running?

comment:6 Changed on Sep 2, 2019 at 8:02:11 AM by softgrow

  • Resolution set to duplicate
  • Status changed from reopened to closed

Ok, looks to be a duplicate of another bug. I saw it on 6.9.4 but is fixed in 7.0.2 (OSX via brew.sh)

$ duck --help
Usage:duck [options...]
...
                        Windows Azure Blob Storage azure:(//<hostname>)/<container>/<key>
                        Backblaze B2 Cloud Storage b2:/<container>/<key>
                              Google Cloud Storage gs:/<container>/<key>
                                         Amazon S3 s3:(//<hostname>)/<container>/<key>
                        Rackspace Cloud Files (US) rackspace:/<container>/<key>
                  Swift (OpenStack Object Storage) swift://<hostname>/<container>/<key>

                                   DRACOON (OAuth) dracoon:(//<hostname>)/<folder>/<file>
...
open a ticket at https://trac.cyberduck.io/newticket?version=7.0.2.
Not registered. Purchase a donation key to support the development of this software.
Note: See TracTickets for help on using tickets.
swiss made software