Cyberduck Mountain Duck CLI

#10817 closed defect (duplicate)

Access denied (Please verify disk permissions) when downloading folder with multiple files

Reported by: MichaelEckstein Owned by: lvogt
Priority: normal Milestone: 7.3.0
Component: googledrive Version: 7.1
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 10

Description

Hello !

Since some days I get the error Message "Access denied (Please verify disk permissions)" when I try to download Files from my Google Drive Cryptomator vault. I already updated to the newest Snapshout Build (31514), but the error persists. I can reproduce the error on 3 different Computers... Interesting is, that I can download files I`ve uploaded 3 month ago without any problem...

Any ideas ?

best regards Michael

Attachments (6)

Access_Denied.jpg (22.6 KB) - added by MichaelEckstein on Oct 1, 2019 at 6:08:50 PM.
Access_Denied_1.jpg (135.8 KB) - added by MichaelEckstein on Oct 1, 2019 at 6:08:59 PM.
Access_Denied_2.jpg (129.6 KB) - added by MichaelEckstein on Oct 1, 2019 at 6:09:09 PM.
Access_Denied_3.jpg (136.9 KB) - added by MichaelEckstein on Oct 1, 2019 at 6:09:18 PM.
Access_Denied_4.jpg (133.6 KB) - added by MichaelEckstein on Oct 1, 2019 at 6:09:27 PM.
Access_Denied_5.jpg (131.6 KB) - added by MichaelEckstein on Oct 1, 2019 at 6:09:34 PM.

Download all attachments as: .zip

Change History (15)

comment:1 Changed on Oct 1, 2019 at 1:51:56 PM by lvogt

  • Owner set to lvogt
  • Status changed from new to assigned

Hi Michael,

Thanks for reaching out. I've tried to reproduce the described issue with the latest release version but can't reproduce it at all. I can download files with different file extensions and sizes from a Cryptomator Vault within Google Drive without any issues.

Does this issue occur in combination with specific files (file extension, file size)? Do you have any additional information that could help us to reproduce the issue?

– Laura

Changed on Oct 1, 2019 at 6:08:50 PM by MichaelEckstein

Changed on Oct 1, 2019 at 6:08:59 PM by MichaelEckstein

Changed on Oct 1, 2019 at 6:09:09 PM by MichaelEckstein

Changed on Oct 1, 2019 at 6:09:18 PM by MichaelEckstein

Changed on Oct 1, 2019 at 6:09:27 PM by MichaelEckstein

Changed on Oct 1, 2019 at 6:09:34 PM by MichaelEckstein

comment:2 Changed on Oct 1, 2019 at 6:11:15 PM by MichaelEckstein

Hello Laura !

Thanks for your answer. After I`ve done some Tests I figured out, that Single File downloads are working. When I try to download a Folder with 3 Files in it I get the Error "Access denied". The size of the Folder with the 3 Files in it is about 4 GB. Aboluteley curious is, that I can download Folders with the same size and same kind of files, I have uploaded 3 month ago, without any problem ! I will append some screenshots.. Maybe the information help..

best regards Michael

comment:3 Changed on Oct 1, 2019 at 6:14:39 PM by dkocher

  • Component changed from core to googledrive

comment:4 Changed on Oct 8, 2019 at 9:09:56 AM by dkocher

  • Component changed from googledrive to core
  • Milestone changed from 7.1.1 to 8.0
  • Summary changed from Access denied (Please verify disk permissions) when downloading from Google Drive Cryptomator vault.... to Access denied (Please verify disk permissions) when downloading folder with multiple files

comment:5 Changed on Oct 9, 2019 at 3:07:09 PM by lvogt

Hi Michael,

Thanks for the information. I've tried to reproduce the issue again and can reproduce it. We'll look into this and report back as soon as possible.

– Laura

comment:6 Changed on Oct 9, 2019 at 3:13:26 PM by jmalek

Files identified as abusive (malware, etc.) are only downloadable by the owner. Additionally, the query parameter acknowledgeAbuse=true must be included to indicate that the user has acknowledged the risk of downloading potential malware. Your application should interactively warn the user before using this query parameter.

This is caused by Google Drive identifying the file as potentially abusive and / or is unable to scan the file - as intended as Google should not have access to Cryptomator files. Thus it sees files as potential risk and denies access to Cryptomator files. This happens randomly and is not related to downloading folders with multiple files, but opening vaults and accessing any file inside Cryptomator vaults.

This can only be omitted by adding acknowledgeAbuse=true to our query to download files as in Download files | Google Drive Api | Google Developers

comment:7 Changed on Oct 11, 2019 at 7:22:02 PM by dkocher

  • Component changed from core to googledrive

comment:8 Changed on Oct 23, 2019 at 8:56:06 AM by dkocher

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate for #10377.

comment:9 Changed on Mar 22, 2020 at 1:21:17 PM by dkocher

  • Milestone changed from 8.0 to 7.3.0
Note: See TracTickets for help on using tickets.
swiss made software