Cyberduck Mountain Duck CLI

#10832 closed defect (worksforme)

Unable to delete file

Reported by: MarkBlaise Owned by: dkocher
Priority: normal Milestone:
Component: s3 Version: 7.1
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Windows 10

Description

When I try to delete a file, I get the message shown in attached file. What does this mean? Is there any workaround?

Attachments (1)

Cant-Delete.jpg (57.3 KB) - added by MarkBlaise on Oct 5, 2019 at 3:18:05 PM.
message seen when trying to delete a file in Cyberduck GUI

Download all attachments as: .zip

Change History (8)

Changed on Oct 5, 2019 at 3:18:05 PM by MarkBlaise

message seen when trying to delete a file in Cyberduck GUI

comment:1 Changed on Oct 6, 2019 at 10:00:06 AM by dkocher

Please post the transcript from the log drawer and specify if you are connecting to AWS or which third party S3 implementation (Wasabi?).

comment:2 Changed on Oct 6, 2019 at 10:00:14 AM by dkocher

  • Component changed from core to s3
  • Owner set to dkocher

comment:3 Changed on Oct 6, 2019 at 5:51:21 PM by MarkBlaise

Yes,using Wasabi. Here's the content of the Log Drawer when I try to delete a file.

Note that I inserted a string of equal signs after the delete attempt fails and the error message is displayed. The text after the equal signs was added to the Log Drawer after I clicked "Cancel" on the error message dialog.

DELETE /blaise-backup-west/Magni/Full/20190903-Text-File-Test.nbd HTTP/1.1
Date: Sun, 06 Oct 2019 17:42:25 GMT
x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
Host: s3.wasabisys.com
x-amz-date: 20191006T174225Z
Authorization: ********
Connection: Keep-Alive
User-Agent: Cyberduck/7.0.2.30998 (Windows 10/10.0) (x86)
HTTP/1.1 301 Moved Permanently
Content-Type: application/xml
Date: Sun, 06 Oct 2019 17:42:25 GMT
Location: https://s3.us-west-1.wasabisys.com/blaise-backup-west/Magni/Full/20190903-Text-File-Test.nbd
Server: WasabiS3/4.0.1648-2019-09-30-f54273e (head05)
x-amz-bucket-region: us-west-1
x-amz-id-2: 1k+oPHXF/0t93tXCJoonSiwL2TKPM7xo+EtVSz/AityBzTYrOmCJBsm6+DPPm83Cyhi/y6RIgCiN
x-amz-request-id: 7AD1C3D8CB51F3CC
Transfer-Encoding: chunked
==============================================================
GET /blaise-backup-west/?max-keys=1000&prefix=Magni%2FFull%2F&delimiter=%2F HTTP/1.1
Date: Sun, 06 Oct 2019 17:42:54 GMT
x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
Host: s3.wasabisys.com
x-amz-date: 20191006T174254Z
Authorization: ********
Connection: Keep-Alive
User-Agent: Cyberduck/7.0.2.30998 (Windows 10/10.0) (x86)
HTTP/1.1 301 Moved Permanently
Content-Type: application/xml
Date: Sun, 06 Oct 2019 17:42:54 GMT
Location: https://s3.us-west-1.wasabisys.com/blaise-backup-west/?max-keys=1000&prefix=Magni%2FFull%2F&delimiter=%2F
Server: WasabiS3/4.0.1648-2019-09-30-f54273e (head05)
x-amz-bucket-region: us-west-1
x-amz-id-2: omALRegwWo1KRsAYmjiNP3KuDsc55odZ9dbnV0t0XXv/BjWYI0a1xFZpLAPqMo+GgI3Tzk7Ju3v/
x-amz-request-id: FF0BF2872F587CBB
Transfer-Encoding: chunked
GET /blaise-backup-west/?max-keys=1000&prefix=Magni%2FFull%2F&delimiter=%2F HTTP/1.1
Date: Sun, 06 Oct 2019 17:42:54 GMT
x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
Host: s3.wasabisys.com
x-amz-date: 20191006T174254Z
Authorization: ********
Connection: Keep-Alive
User-Agent: Cyberduck/7.0.2.30998 (Windows 10/10.0) (x86)
HTTP/1.1 200 OK
Content-Type: application/xml
Date: Sun, 06 Oct 2019 17:42:55 GMT
Server: WasabiS3/4.0.1648-2019-09-30-f54273e (head02)
x-amz-bucket-region: us-west-1
x-amz-id-2: ReurnMAFkEyO2AnhF2BC5FFNlgyGQB5mWANNegj27kaEavrkQrSefjpkEOcVdAOmo8HFN2arUsMY
x-amz-request-id: 3D261504671AD577
Transfer-Encoding: chunked
GET /blaise-backup-west/?prefix=Magni%2FFull%2F&uploads HTTP/1.1
Date: Sun, 06 Oct 2019 17:42:55 GMT
x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
Host: s3.wasabisys.com
x-amz-date: 20191006T174255Z
Authorization: ********
Connection: Keep-Alive
User-Agent: Cyberduck/7.0.2.30998 (Windows 10/10.0) (x86)
HTTP/1.1 301 Moved Permanently
Content-Type: application/xml
Date: Sun, 06 Oct 2019 17:42:56 GMT
Location: https://s3.us-west-1.wasabisys.com/blaise-backup-west/?prefix=Magni%2FFull%2F&uploads
Server: WasabiS3/4.0.1648-2019-09-30-f54273e (head05)
x-amz-bucket-region: us-west-1
x-amz-id-2: AxMMzfzzT11mZ8Xlzs0cyVAGSB19bCZtPZqFpWCHYlIprtWn3IK1pNjL1p9caOKHt5idTqzQ7DMO
x-amz-request-id: 92BE7A123360C02A
Transfer-Encoding: chunked
GET /blaise-backup-west/?prefix=Magni%2FFull%2F&uploads HTTP/1.1
Date: Sun, 06 Oct 2019 17:42:55 GMT
x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
Host: s3.wasabisys.com
x-amz-date: 20191006T174255Z
Authorization: ********
Connection: Keep-Alive
User-Agent: Cyberduck/7.0.2.30998 (Windows 10/10.0) (x86)
HTTP/1.1 200 OK
Content-Type: application/xml
Date: Sun, 06 Oct 2019 17:42:56 GMT
Server: WasabiS3/4.0.1648-2019-09-30-f54273e (head02)
x-amz-id-2: jt+8Qc9ZEnWceI2vtewvl2jJfkW7ahOY+hmyS2CcBiLiQ+w19+YpoPuWmicfsXQub0U9dGrHVOTZ
x-amz-request-id: 2A3FFFD75CFD2028
Transfer-Encoding: chunked

comment:4 Changed on Oct 6, 2019 at 6:33:23 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Please install the region us-west-1connection profile from https://cyberduck.io/wasabi/

comment:5 Changed on Oct 7, 2019 at 3:39:35 AM by MarkBlaise

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I downloaded and installed that profile some time ago. I can upload and download files, and get a directory listing. Only deletion fails.

Any other thoughts?

comment:6 Changed on Oct 23, 2019 at 6:28:32 PM by dkocher

Please post the transcript from the log drawer (⌘-L).

comment:7 Changed on Oct 23, 2019 at 6:30:17 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

I cannot reproduce the issue

DELETE /cyberduck-us-west-1/10-3.png HTTP/1.1
Date: Wed, 23 Oct 2019 18:29:31 GMT
x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
Host: s3.us-west-1.wasabisys.com
x-amz-date: 20191023T182931Z
Authorization: ********
Connection: Keep-Alive
User-Agent: Cyberduck/7.1.2.31600 (Mac OS X/10.14.6) (x86_64)
HTTP/1.1 204 No Content
Date: Wed, 23 Oct 2019 18:29:31 GMT
Server: WasabiS3/4.0.1800-2019-10-16-830c155 (head04)
x-amz-id-2: akEp09zOM6TN4xlMJVNuF6rNXWk6G5Jmb5xoIGoyZeWTG0nTkcIU2wuhjhXqnltbeprVcECGLVl3
x-amz-request-id: 0DDA494201AD9419

Note: See TracTickets for help on using tickets.
swiss made software