Cyberduck Mountain Duck CLI

#10838 closed defect (fixed)

Cannot override trust for invalid certificate

Reported by: DesertEagle61 Owned by: dkocher
Priority: normal Milestone: 7.2
Component: webdav Version: 7.1
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 10

Description (last modified by dkocher)

Since upgrading to version 7.1.1 I am constantly getting the following error: "This certificate is not valid". Clicking on "Always trust" does not help. The error is popping up constantly. This is very annoying!

As having application specific proxy settings is not allowed (I have created another ticket for that), I do not see any way I can fix this within the application by changing some settings.

It is very similar to the following old issue #2938

Change History (10)

Changed on Oct 9, 2019 at 9:07:58 AM by DesertEagle61

Screenshot

comment:1 Changed on Oct 9, 2019 at 9:11:01 AM by dkocher

  • Description modified (diff)

comment:2 Changed on Oct 11, 2019 at 7:35:24 PM by dkocher

  • Component changed from core to webdav
  • Milestone set to 8.0
  • Owner set to dkocher
  • Priority changed from highest to normal
  • Status changed from new to assigned
  • Summary changed from This certificate is not valid to Cannot override trust for invalid certificate

comment:3 Changed on Oct 24, 2019 at 8:32:16 AM by dkocher

  • Milestone changed from 8.0 to 7.1.2

comment:4 Changed on Oct 25, 2019 at 2:27:05 PM by yla

I'm not able to reproduce the issue. Can you please check if you have an entry de.coia.siemens.net.certificate.accept in %APPDATA%\iterate_GmbH\Cyberduck.exe_Url_[id]\[version]\user.config? The value of this entry should match the thumbprint of the server certificate.

comment:5 Changed on Oct 29, 2019 at 9:40:30 AM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:6 Changed on Nov 11, 2019 at 3:31:53 PM by DesertEagle61

  • Resolution worksforme deleted
  • Status changed from closed to reopened

The entry is there, please see attached screenshot.

comment:7 Changed on Nov 26, 2019 at 3:11:01 PM by dkocher

  • Milestone changed from 7.1.2 to 8.0

comment:8 Changed on Dec 12, 2019 at 9:26:41 AM by dkocher

  • Milestone changed from 8.0 to 7.2
  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software