Cyberduck Mountain Duck CLI

#10847 closed defect (thirdparty)

501 Not Implemented reading versioning configuration (AWS Snowball S3 Uploads failing)

Reported by: greendm Owned by: dkocher
Priority: normal Milestone: 7.1.2
Component: s3 Version: 7.1
Severity: normal Keywords:
Cc: greendm@… Architecture: Intel
Platform: macOS 10.14

Description

Hello,

I am attempting to upload a 1GB file to a local AWS Snowball using the "S3 http" profile. This worked in previous versions of CyberDuck, but I'm unfortunately unsure when the issue started.

I have been able to upload smaller files (10's of MB), but the larger files are not transferring. I do not notice any local disk or CPU activity during the attempted transfer.

The debug output is attached to the ticket.

Attachments (1)

cyberduck-greendm-snowball.txt (781.9 KB) - added by greendm on Oct 18, 2019 at 4:01:02 PM.
AWS Snowball debug log

Download all attachments as: .zip

Change History (6)

Changed on Oct 18, 2019 at 4:01:02 PM by greendm

AWS Snowball debug log

comment:1 Changed on Oct 23, 2019 at 6:31:39 PM by dkocher

  • Component changed from core to s3
  • Owner set to dkocher
  • Status changed from new to assigned
Sep 27 13:46:22 mbp10g Cyberduck[18441]: [Thread-36] DEBUG org.jets3t.service.impl.rest.httpclient.RestStorageService - Rethrowing as a ServiceException error in performRequest: org.jets3t.service.ServiceException: Service Error Message. -- ResponseCode: 501, ResponseStatus: null, XML Error Message: <?xml version="1.0" encoding="UTF-8" standalone="yes"?><Error xsi:schemaLocation="http://s3.amazonaws.com/doc/2006-03-01/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">    <Code>NotImplemented</Code>    <Message>The specified API is not implemented yet</Message></Error>
942	Sep 27 13:46:22 mbp10g Cyberduck[18441]: [Thread-36] DEBUG org.jets3t.service.impl.rest.httpclient.RestStorageService - Releasing HttpClient connection after error: Service Error Message.
943	Sep 27 13:46:22 mbp10g Cyberduck[18441]: [Thread-36] DEBUG org.apache.http.impl.execchain.MainClientExec - Cancelling request execution
944	Sep 27 13:46:22 mbp10g Cyberduck[18441]: [Thread-36] WARN  ch.cyberduck.core.s3.S3VersioningFeature - Not supported to read versioning configuration for Path{path='/s3bucketname', type=[directory, volume]} Service Error Message.

comment:2 Changed on Oct 23, 2019 at 6:32:39 PM by dkocher

  • Milestone set to 7.1.2
  • Summary changed from AWS Snowball S3 Uploads Failing to 501 Not Implemented reading versioning configuration (AWS Snowball S3 Uploads failing)
Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.request - GET /s3bucketname/?versioning HTTP/1.1
1465	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.request - Date: Fri, 27 Sep 2019 20:46:24 GMT
1466	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.request - x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
1467	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.request - Host: 10.10.10.10
1468	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.request - x-amz-date: 20190927T204624Z
1469	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.request - Authorization: ********
1470	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.request - Connection: Keep-Alive
1471	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.request - User-Agent: Cyberduck/7.1.1.31396 (Mac OS X/10.14.6) (x86_64)
1485	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.response - HTTP/1.1 501 Not Implemented
1486	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.response - Content-Type: text/xml
1487	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.response - Content-Length: 284
1488	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.response - Server: AmazonSnowball
1489	Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  ch.cyberduck.transcript.response - Keep-Alive: timeout=89

comment:3 Changed on Oct 23, 2019 at 6:36:42 PM by dkocher

Actually this is silently ignored

Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] WARN  ch.cyberduck.core.s3.S3VersioningFeature - Not supported to read versioning configuration for Path{path='/s3bucketname', type=[directory, volume]} Service Error Message.

comment:4 Changed on Oct 23, 2019 at 6:39:28 PM by dkocher

Some intermittent I/O failure but this does not seem the cause of the problem.

Sep 27 13:46:24 mbp10g Cyberduck[18441]: [Thread-38] INFO  org.apache.http.impl.execchain.RetryExec - I/O exception (org.apache.http.NoHttpResponseException) caught when processing request to {}->http://10.10.10.10:8080: The target server failed to respond

comment:5 Changed on Oct 23, 2019 at 6:42:58 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from assigned to closed
Sep 27 13:46:28 mbp10g Cyberduck[18441]: [main] DEBUG ch.cyberduck.core.threading.TransferCollectionBackgroundAction - Cancel background action for transfer Transfer{transferred=0, size=1046760821, roots=[TransferItem{local=Local{path='/Users/greendm/Desktop/files/1GB.mp4'}, remote=Path{path='/s3bucketname/1GB.mp4', type=[file]}}], state=running, host=Host{protocol=Profile{parent=s3, vendor=s3-http, description=S3 (HTTP), image=null}, port=8080, hostname='10.10.10.10', credentials=Credentials{user='AKIACEMGUYTOOJXG4YTMNBRHA377WLC5RDQU5UKFERIBJUK3QLZ', token='null', identity=null}, uuid='261bb90e-72fb-410c-a18f-47ec63b79a72', nickname='DG SBE', defaultpath='null'}}

Do you manually cancel the transfer or is there any alert displayed? We see other I/O failures

Sep 27 13:46:25 mbp10g Cyberduck[18441]: [multipart-10] WARN  ch.cyberduck.core.threading.AbstractRetryCallable - Retry for failure BackgroundException{file=Path{path='/', type=[directory]}, message='Connection failed', detail='Broken pipe (Write failed).', cause='java.net.SocketException: Broken pipe (Write failed)'} with delay of 0s

It looks like the connection to the Snowball is not stable.

Note: See TracTickets for help on using tickets.
swiss made software