Cyberduck Mountain Duck CLI

#10859 closed defect (fixed)

Uploading large files to an online-only OneDrive Cryptomator vault always cancels with "Internal server error"

Reported by: rootie Owned by: jmalek
Priority: high Milestone: 7.2
Component: onedrive Version: 7.1
Severity: major Keywords:
Cc: Architecture: Intel
Platform: macOS 10.15

Description

Hi,

there's an issue with the newest version of Cyberduck that keeps the user from uploading large files (I've tried to upload an 8 GB file) to an online-only OneDrive Cryptomator vault.

It starts uploading but always stops with an error message "Internal server error" - there's no sign on when it stops. Sometimes after 100 MB, sometimes after 500 MB, but it never succeeds.

I've tried with the last three versions of Cyberduck but they all fail.

To reproduce this, just try to upload a single large file to an online-only Cryptomator vault on OneDrive.

Please analyze and fix this issue.

Attachments (1)

Log.txt (1.8 MB) - added by rootie on Nov 17, 2019 at 8:46:44 AM.

Download all attachments as: .zip

Change History (6)

comment:1 Changed on Nov 11, 2019 at 8:07:07 PM by rootie

Any news here? This is quite a serious issue. I can help if there are any problems in reproducing it.

comment:2 Changed on Nov 15, 2019 at 4:16:15 PM by lvogt

Hi,

Thanks for reaching out and apologies for the belated answer.

I've tried to reproduce the described issue but can't reproduce it at all.

Please send us the transfer transcript entries right after the issue occurs again. To reach the transcript entries choose View → Toggle Log Drawer while the Cyberduck transfer window is in focus. Right after you can see the log drawer attempt to upload a large file and if it fails, send us the entries in a text file.

– Laura

comment:3 Changed on Nov 17, 2019 at 8:46:28 AM by rootie

Hi,

I've attached the file Log.txt. The error comes out of nowhere and unfortunately it's not possible to resume the upload altogether.

I've tried uploading the Windows 10 ISO file which can be downloaded from here: https://software-download.microsoft.com/db/Win10_1909_German_x64.iso?t=1a1fd620-0189-429f-b695-e196c7af9586&e=1574060526&h=2be821c93889af51d784bd866588b004

I'm not sure how long the link is valid, but you can always go to this page (in German) and download it: https://winfuture.de/downloadvorschalt,3891.html

Best regards, rootie

Changed on Nov 17, 2019 at 8:46:44 AM by rootie

comment:4 Changed on Nov 25, 2019 at 2:27:47 PM by jmalek

  • Owner set to jmalek
  • Status changed from new to assigned

OneDrive accepts your upload with an HTTP/1.1 500 Internal Server Error - which in terms means that the OneDrive server went into an invalid state rendering your upload unusable. I tried reproducing your issue but haven't been able to get any error - a Windows ISO has been successfully transferred to OneDrive - though it's not been in the FRA-datacenter. We are looking into improving the situation here to retry uploading a fragment at a later time.

comment:5 Changed on Nov 26, 2019 at 3:12:02 PM by dkocher

  • Milestone set to 7.2
  • Resolution set to fixed
  • Status changed from assigned to closed

In r48221.

Note: See TracTickets for help on using tickets.
swiss made software