Cyberduck Mountain Duck CLI

#10870 closed defect (worksforme)

Window handling

Reported by: hmp2019 Owned by: dkocher
Priority: normal Milestone: 7.2.2
Component: interface Version: 7.1
Severity: critical Keywords: Window handling
Cc: Architecture: Intel
Platform: macOS 10.15

Description

Since v.7.12 Cyberduck did not always open a new window for a new connection (from bookmarks). Cyberduck re-use an existing window and switch the connection. Example: one window with server A, one with Server B. If I open another connection for Server C, Cyberduck re-use one of the windows for Server A or B to connect Server C. This wasn't before the latest update.

Change History (5)

comment:1 Changed on Nov 6, 2019 at 12:52:48 PM by dkocher

  • Component changed from core to interface
  • Milestone set to 8.0
  • Owner set to dkocher
  • Priority changed from high to normal
  • Status changed from new to assigned
  • Version set to 7.1

comment:2 follow-up: Changed on Nov 28, 2019 at 9:52:02 AM by dkocher

I cannot reproduce that a new window would be opened when double clicking a bookmark to connect. Do you refer to the restore of windows when re-opening the application?

comment:3 in reply to: ↑ 2 Changed on Nov 28, 2019 at 11:21:05 AM by hmp2019

Replying to dkocher:

I cannot reproduce that a new window would be opened when double clicking a bookmark to connect. Do you refer to the restore of windows when re-opening the application?

no. If Cyberduck already running and one connection-window is open, I choose new a connection from the bookmark menu. Sometimes it will open a new window, sometimes CD will switch the connection of the existing window. Same will happen if I select "show bookmarks" and choose another connection from there. Also sometimes "show bookmarks" will shown in on existing connection-window instead of open a new window. A very annoying behavior!

comment:4 Changed on Dec 11, 2019 at 10:41:08 AM by dkocher

  • Milestone changed from 8.0 to 7.2.2
  • Resolution set to worksforme
  • Status changed from assigned to closed

I cannot reproduce this. This should always open the connection in the current open browser window.

comment:5 Changed on Dec 11, 2019 at 11:36:18 AM by hmp2019

" This should always open the connection in the current open browser window."? Why? This is not a feature, this is a bug and wasn't like this before in previous versions of Cyber Duck. If you working with several different server, you need for each one a own connection window! At least it should be configurable in the settings.

Note: See TracTickets for help on using tickets.
swiss made software