Cyberduck Mountain Duck CLI

#10871 closed defect (fixed)

All downloads fail when Azure SAS authentication is used

Reported by: yla Owned by:
Priority: normal Milestone: 7.2
Component: azure Version: 7.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

java.lang.Exception
	at ch.cyberduck.core.threading.BackgroundCallable.<init>(BackgroundCallable.java:36)
	at ch.cyberduck.core.threading.DefaultBackgroundExecutor.execute(DefaultBackgroundExecutor.java:67)
	at ch.cyberduck.core.AbstractController.background(AbstractController.java:71)
	at ch.cyberduck.ui.cocoa.controller.BrowserController.edit(BrowserController.java:2407)
	at ch.cyberduck.ui.cocoa.controller.BrowserController.edit(BrowserController.java:2403)
	at ch.cyberduck.ui.cocoa.controller.BrowserController.editButtonClicked(BrowserController.java:2398)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.base/java.lang.reflect.Method.invoke(Unknown Source)
	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:171)
	at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:53)
	at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:83)
	at jdk.internal.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.base/java.lang.reflect.Method.invoke(Unknown Source)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:520)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:551)
	at com.sun.jna.Native.invokeVoid(Native Method)
	at com.sun.jna.Function.invoke(Function.java:415)
	at com.sun.jna.Function.invoke(Function.java:361)
	at com.sun.jna.Function.invoke(Function.java:315)
	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
	at com.sun.jna.Library$Handler.invoke(Library.java:263)
	at com.sun.proxy.$Proxy3.syntheticSendMessage(Unknown Source)
	at org.rococoa.Foundation.send(Foundation.java:209)
	at org.rococoa.Foundation.send(Foundation.java:195)
	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:270)
	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:233)
	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:192)
	at ch.cyberduck.binding.application.NSApplication$$ByRococoa.run(<generated>)
	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:124)
Caused by: java.lang.IllegalArgumentException: Cannot create Shared Access Signature unless the Account Key credentials are used by the ServiceClient.
	at com.microsoft.azure.storage.blob.CloudBlob.generateSharedAccessSignature(CloudBlob.java:2213)
	at com.microsoft.azure.storage.blob.CloudBlob.generateSharedAccessSignature(CloudBlob.java:2177)
	at com.microsoft.azure.storage.blob.CloudBlob.generateSharedAccessSignature(CloudBlob.java:2148)
	at ch.cyberduck.core.azure.AzureUrlProvider.createSignedUrl(AzureUrlProvider.java:88)
	at ch.cyberduck.core.azure.AzureUrlProvider.toUrl(AzureUrlProvider.java:63)
	at ch.cyberduck.core.vault.registry.VaultRegistryUrlProvider.toUrl(VaultRegistryUrlProvider.java:40)
	at ch.cyberduck.core.transfer.download.AbstractDownloadFilter.complete(AbstractDownloadFilter.java:340)
	at ch.cyberduck.core.worker.AbstractTransferWorker$3.call(AbstractTransferWorker.java:395)
	at ch.cyberduck.core.worker.SingleTransferWorker.submit(SingleTransferWorker.java:70)
	at ch.cyberduck.core.worker.AbstractTransferWorker.transfer(AbstractTransferWorker.java:371)
	at ch.cyberduck.core.worker.AbstractTransferWorker.run(AbstractTransferWorker.java:221)
	at ch.cyberduck.core.editor.EditOpenWorker.run(EditOpenWorker.java:96)
	at ch.cyberduck.core.editor.EditOpenWorker.run(EditOpenWorker.java:51)
	at ch.cyberduck.core.threading.WorkerBackgroundAction.run(WorkerBackgroundAction.java:77)
	at ch.cyberduck.core.threading.SessionBackgroundAction.run(SessionBackgroundAction.java:134)
	at ch.cyberduck.core.threading.SessionBackgroundAction$1.call(SessionBackgroundAction.java:116)
	at ch.cyberduck.core.threading.DefaultRetryCallable.call(DefaultRetryCallable.java:50)
	at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:118)
	at ch.cyberduck.core.threading.BackgroundCallable.run(BackgroundCallable.java:94)
	at ch.cyberduck.core.threading.BackgroundCallable.call(BackgroundCallable.java:58)

Change History (3)

comment:1 Changed on Nov 12, 2019 at 3:06:18 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r48098.

comment:2 Changed on Nov 15, 2019 at 11:35:08 AM by dkocher

  • Milestone changed from 8.0 to 7.1.3

comment:3 Changed on Nov 22, 2019 at 9:36:20 AM by dkocher

  • Milestone changed from 7.1.3 to 7.2

Milestone renamed

Note: See TracTickets for help on using tickets.
swiss made software