Cyberduck Mountain Duck CLI

#10886 closed defect (fixed)

S3 pre-signed URL doesn't work

Reported by: leon.li Owned by: dkocher
Priority: normal Milestone: 7.2.2
Component: s3 Version: 7.1.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

The S3 pre-signed URL can't be visited. Error like below:

<Error>
<Code>InvalidRequest</Code>
<Message>
The authorization mechanism you have provided is not supported. Please use AWS4-HMAC-SHA256.
</Message>
<RequestId>FEAC288AB9E9765C</RequestId>
<HostId>
lMFCiJnwzWpEX9glXBVNl/kVOCq35IjhiSvO814mkQN6dTMNP7QhGYH3wlN6JICu2b8D7QHq8n4=
</HostId>
</Error>

Change History (8)

comment:1 Changed on Nov 27, 2019 at 9:08:09 AM by dkocher

  • Description modified (diff)

comment:2 Changed on Nov 27, 2019 at 9:08:22 AM by dkocher

  • Component changed from core to s3
  • Owner set to dkocher
  • Priority changed from highest to normal
  • Severity changed from blocker to normal

comment:3 Changed on Nov 27, 2019 at 9:11:09 AM by dkocher

I cannot reproduce this error. Can you share an example of a pre-signed URL that is showing this error.

comment:5 Changed on Nov 28, 2019 at 9:16:19 AM by dkocher

Do you use the S3 China (Beijing) connection profile from https://cyberduck.io/s3/?

comment:6 Changed on Nov 28, 2019 at 9:21:13 AM by dkocher

  • Milestone set to 8.0
  • Status changed from new to assigned

comment:7 Changed on Nov 28, 2019 at 9:48:25 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r48255.

comment:8 Changed on Dec 6, 2019 at 2:12:52 PM by dkocher

  • Milestone changed from 8.0 to 7.2.2
Note: See TracTickets for help on using tickets.
swiss made software