Cyberduck Mountain Duck CLI

#10908 closed defect (fixed)

Error constructing implementation (algorithm: DEFAULT, provider: BC,

Reported by: MarkBlaise Owned by: dkocher
Priority: highest Milestone: 7.2.2
Component: cli Version: 7.2.1
Severity: blocker Keywords:
Cc: Architecture: Intel
Platform: Windows 10

Description

On Win 10-64, updated Duck CLI from 7.1.2.31675 to 7.2.1.31913 via MSI. Any command now crashes:

Microsoft Windows [Version 10.0.18363.535]
(c) 2019 Microsoft Corporation. All rights reserved.

C:\Users\Mark>duck --version
log4j:WARN No appenders could be found for logger (ch.cyberduck.core.preferences.Preferences).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
java.lang.ExceptionInInitializerError
        at java.util.UUID.randomUUID(UUID.java:142)
        at ch.cyberduck.core.UUIDRandomStringService.random(UUIDRandomStringService.java:23)
        at ch.cyberduck.core.local.DefaultTemporaryFileService.create(DefaultTemporaryFileService.java:45)
        at ch.cyberduck.core.Profile.write(Profile.java:249)
        at ch.cyberduck.core.Profile.<init>(Profile.java:55)
        at ch.cyberduck.core.serializer.ProfileDictionary.deserialize(ProfileDictionary.java:69)
        at ch.cyberduck.core.serializer.impl.dd.ProfilePlistReader.deserialize(ProfilePlistReader.java:52)
        at ch.cyberduck.core.serializer.impl.dd.ProfilePlistReader.deserialize(ProfilePlistReader.java:28)
        at ch.cyberduck.core.serializer.impl.dd.PlistReader.read(PlistReader.java:89)
        at ch.cyberduck.core.serializer.impl.dd.PlistReader.read(PlistReader.java:81)
        at ch.cyberduck.core.ProtocolFactory.loadDefaultProfiles(ProtocolFactory.java:79)
        at ch.cyberduck.cli.Terminal.execute(Terminal.java:232)
        at ch.cyberduck.cli.Terminal.open(Terminal.java:172)
        at cli.Ch.Cyberduck.Cli.WindowsTerminal.Main(Unknown Source)
Caused by: java.lang.RuntimeException: java.security.NoSuchAlgorithmException: Error constructing implementation (algorithm: DEFAULT, provider: BC, class: org.bouncycastle.jcajce.provider.drbg.DRBG$Default)
        at java.security.SecureRandom.getDefaultPRNG(SecureRandom.java:213)
        at java.security.SecureRandom.<init>(SecureRandom.java:163)
        at java.util.UUID$Holder.<clinit>(UUID.java:96)
        ... 2 more
Caused by: java.security.NoSuchAlgorithmException: Error constructing implementation (algorithm: DEFAULT, provider: BC, class: org.bouncycastle.jcajce.provider.drbg.DRBG$Default)
        at java.security.Provider$Service.newInstance(Provider.java:1619)
        at sun.security.jca.GetInstance.getInstance(GetInstance.java:236)
        at sun.security.jca.GetInstance.getInstance(GetInstance.java:164)
        at java.security.SecureRandom.getInstance(SecureRandom.java:288)
        at java.security.SecureRandom.getDefaultPRNG(SecureRandom.java:205)
        at java.security.SecureRandom.<init>(SecureRandom.java:163)
        at java.util.UUID$Holder.<clinit>(UUID.java:96)
        at java.util.UUID.randomUUID(UUID.java:142)
        at ch.cyberduck.core.UUIDRandomStringService.random(UUIDRandomStringService.java:23)
        at ch.cyberduck.core.local.DefaultTemporaryFileService.create(DefaultTemporaryFileService.java:45)
        at ch.cyberduck.core.Profile.write(Profile.java:249)
        at ch.cyberduck.core.Profile.<init>(Profile.java:55)
        at ch.cyberduck.core.serializer.ProfileDictionary.deserialize(ProfileDictionary.java:69)
        at ch.cyberduck.core.serializer.impl.dd.ProfilePlistReader.deserialize(ProfilePlistReader.java:52)
        at ch.cyberduck.core.serializer.impl.dd.ProfilePlistReader.deserialize(ProfilePlistReader.java:28)
        at ch.cyberduck.core.serializer.impl.dd.PlistReader.read(PlistReader.java:89)
        at ch.cyberduck.core.serializer.impl.dd.PlistReader.read(PlistReader.java:81)
        at ch.cyberduck.core.ProtocolFactory.loadDefaultProfiles(ProtocolFactory.java:79)
        at ch.cyberduck.cli.Terminal.execute(Terminal.java:232)
        ... 2 more
Caused by: java.lang.NoClassDefFoundError: Could not initialize class Default
        at org.bouncycastle.jcajce.provider.drbg.DRBG$Default.<init>(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:414)
        at java.security.Provider$Service.newInstance(Provider.java:1595)
        ... 20 more

C:\Users\Mark>

Change History (5)

comment:1 Changed on Dec 15, 2019 at 10:54:29 AM by dkocher

  • Milestone set to 7.2.2
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Dec 15, 2019 at 11:00:03 AM by dkocher

  • Summary changed from DUCK CLI crash after update to Error constructing implementation (algorithm: DEFAULT, provider: BC,

comment:3 Changed on Dec 15, 2019 at 11:00:42 AM by dkocher

Supposed to be fixed with r48223.

comment:4 Changed on Dec 15, 2019 at 5:47:04 PM by dkocher

Changeset r48213 must also be applied to CLI preferences.

comment:5 Changed on Dec 15, 2019 at 6:06:37 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r48369.

Note: See TracTickets for help on using tickets.