Cyberduck Mountain Duck CLI

#10973 closed defect (worksforme)

S3 ACL Changes on Save

Reported by: epandasa Owned by:
Priority: normal Milestone:
Component: s3 Version: 7.2.5
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Windows 10

Description

If you edit a file in your S3 Bucket which has reading rights for everyone, those rights get removed and only the rights of the cyberduck user are set.

How to reproduce:

  1. Create a public accessible file with read permissions for everyone, and special permissions for the cyberduck user
  2. Edit the file via right click (ctrl + K)
  3. Save your edits

I did use Visual Studio Code Insider to make the changes, but this worked fine in the past, so i don't think the problem is with them.

Change History (4)

comment:1 follow-up: Changed on Feb 20, 2020 at 2:55:03 PM by dkocher

Have you selected Preferences → Transfers → Permissions → Uploads → Change permissions?

comment:2 in reply to: ↑ 1 Changed on Feb 20, 2020 at 4:32:23 PM by epandasa

Replying to dkocher:

Have you selected Preferences → Transfers → Permissions → Uploads → Change permissions?

No i have not, i might be able to validate this further tonight when i have access to my other pc, with an older version of cyberduck but on the pc where i had the problem change permissions is unchecked.

comment:3 Changed on Feb 20, 2020 at 8:56:48 PM by epandasa

ok i just verified it, with my older version on this desktop it works just fine, so something must have been broken during those 2 versions on the way, version on this machine is 6.9.4

comment:4 Changed on Feb 26, 2020 at 1:38:25 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this. Make sure Preferences → Transfers → Permissions → Uploads → Change permissions is checked.

Note: See TracTickets for help on using tickets.