Cyberduck Mountain Duck CLI

#10976 closed defect (worksforme)

Gzipped file downloaded truncated

Reported by: alanlbird Owned by: dkocher
Priority: normal Milestone: 7.3.1
Component: google-storage Version: 7.2.5
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

When uploading files that I have gzipped to Google Cloud Storage then downloading them with Cyberduck, I don't get the entire file. The files are truncated to a shorter length, possibly the gzip size instead of the expanded size.

Change History (4)

comment:1 Changed on Feb 26, 2020 at 1:41:53 PM by dkocher

  • Component changed from core to google-storage
  • Owner set to dkocher
  • Summary changed from Downloading gzipped files from Google Cloud Storage doesn't get entire file to Gzipped file downloaded truncated

comment:2 Changed on Apr 28, 2020 at 8:19:10 AM by dkocher

  • Milestone set to 7.3.1
  • Status changed from new to assigned

comment:3 Changed on Apr 28, 2020 at 8:19:47 AM by dkocher

Possible fix in r49121 with changeset from upstream.

comment:4 Changed on Apr 28, 2020 at 8:37:45 AM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

I cannot reproduce the problem. You possibly have a Content-Encoding metadata header set on the file.

Note: See TracTickets for help on using tickets.
swiss made software