Cyberduck Mountain Duck CLI

#10990 closed defect (duplicate)

Download vault from OneDrive stalls

Reported by: Jeroen1000 Owned by: dkocher
Priority: normal Milestone: 7.9.0
Component: cryptomator Version: 7.2.4
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 10

Description (last modified by Jeroen1000)

Hi dev's and fellow users,

I wanted to use Cyberduck to sync an online only (unlocked) Cryptomator vault into backup storage. So an actual copy of the file, not just a placeholder, is saved to this backup storage. Online only storage is not considered a backup.

Anyway, indexing the files (around 10k) seems to take forever. I interrupted the process after half an hour, noticing not a single file had been synced.

When I let Onedrive itself sync the (encrypted) vault folders, it starts saturating a 200 megabit internet connection in under 10 minutes. At that speed the process gets completed well before Cyberduck has finished the indexing step. But this is undesired as I do not want a local copy of the encrypted files.

Is this expected behaviour because to me it feels like abnormally sluggish?

Best regards, Jeroen

Attachments (1)

Cyberduck-stuck-1.png (29.1 KB) - added by dkocher on Apr 8, 2021 at 7:38:38 AM.

Download all attachments as: .zip

Change History (11)

comment:1 Changed on Mar 11, 2020 at 11:50:08 AM by Jeroen1000

  • Description modified (diff)
  • Summary changed from Cyberduck really slow with Onedrive cryptomat container to Cyberduck really slow with Onedrive cryptomator vault

comment:2 Changed on Mar 12, 2020 at 6:08:09 PM by Jeroen1000

I have re-tested yesterday and let it run for +- 4.5 hours. In all that time, Cyberduck was busy indexing (preparing files) but at a certain point got stuck. Basically, I cannot get it to synchronise: not at single file made it to disk. I'll try again with less folders but there must be something wrong I am missing.

comment:3 Changed on Mar 12, 2020 at 6:56:35 PM by dkocher

  • Component changed from core to cryptomator
  • Owner set to yla

comment:4 Changed on Mar 13, 2020 at 7:12:40 AM by Jeroen1000

update:

It seems like a lot of files in nested directories might be the cause. I removed an offending folder (with an exceptionally deep directory structure) and the preparing/indexing completed in about 1u30 hours. Then the download began. It settled around 3 MiB/sec and then halted at Word document. This is at the 50% mark. 10 hours later I found it still at that 50% markt: the download stalled.

Please see screenshot: https://ibb.co/n8V2CBP

Last edited on Mar 13, 2020 at 7:26:28 AM by Jeroen1000 (previous) (diff)

comment:5 Changed on Mar 13, 2020 at 4:31:12 PM by dkocher

  • Summary changed from Cyberduck really slow with Onedrive cryptomator vault to Download vault from OneDrive stalls

Changed on Apr 8, 2021 at 7:38:38 AM by dkocher

comment:7 Changed on Apr 9, 2021 at 8:17:17 AM by dkocher

  • Milestone set to 7.8.6
  • Owner changed from yla to dkocher
  • Status changed from new to assigned

comment:8 Changed on Apr 29, 2021 at 5:20:45 PM by dkocher

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate for #10849 as the fixes will apply here as well.

comment:9 Changed on Apr 29, 2021 at 5:27:41 PM by dkocher

  • Milestone changed from 7.8.6 to 7.9.0

Milestone renamed

comment:10 Changed on Apr 29, 2021 at 7:37:46 PM by dkocher

Please try the current snapshot build by updating from within Cyberduck in Preferences → Update → Automatically check for updates in → Snapshot Builds.

Note: See TracTickets for help on using tickets.