Cyberduck Mountain Duck CLI

#10992 new defect

File not found error when using glob pattern * to upload files

Reported by: Michael_PNZ Owned by:
Priority: normal Milestone:
Component: cli Version: 7.2.5
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 10

Description (last modified by dkocher)

Hello, i use OS windows 8.1 and cyberduck cli 7.2.5.32097, i want upload files in S3 backet. In CMD i write

C:\Program Files\Cyberduck CLI>duck.exe --upload s3://<Access Key ID>@hostname/askbackup17022020/test/ D:\testS3mail\*.exe --existing rename --password <secret key> -q -y

Transfer incomplete. _.exe …
File not found. D:\testS3mail\_.exe. Please contact your web hosting service pro
vider for assistance.

Why glob pattern * is replaced by _

Change History (6)

comment:1 Changed on Mar 13, 2020 at 8:02:22 AM by Michael_PNZ

  • Component changed from core to cli

comment:2 Changed on Mar 13, 2020 at 8:04:26 AM by Michael_PNZ

  • Description modified (diff)

comment:3 Changed on Mar 26, 2020 at 8:37:02 PM by dkocher

  • Description modified (diff)

comment:4 Changed on Apr 15, 2020 at 8:18:48 AM by dkocher

  • Summary changed from Cyberduck CLI - glob pattern * to File not found error when using glob pattern * to upload files

comment:5 Changed on Sep 25, 2020 at 6:31:36 AM by gizzer

  • Platform changed from Windows 8.1 to Windows 10

Hi there,

I can confirm this issue regarding Windows OS (Server 2016). I tried everything (powershell, different patterns) but none of these are working. Duck always converts "*" to "_" and so I'm not able to use it the way it is meant to be.

So please...can you confirm this bug and prepare a bugfix? If you need a tester for the bugfix, please let me know.

Last edited on Sep 25, 2020 at 6:40:47 AM by gizzer (previous) (diff)

comment:6 Changed on Oct 18, 2020 at 7:27:09 PM by dduck

I'd like to add, that downloads with glob pattern don't work for me on macOS, too. Maybe it's because of GNU bash, version 3.2.57(1)-release (x86_64-apple-darwin16), that is shipped with macOS Sierra 10.12.6. The same error "File not found" occurs.

Note: See TracTickets for help on using tickets.