Cyberduck Mountain Duck CLI

#11017 closed defect (worksforme)

Open web URL does not include custom port number

Reported by: jdevrie Owned by:
Priority: normal Milestone:
Component: core Version: 7.3.0
Severity: normal Keywords: port number not in url
Cc: Architecture: Intel
Platform:

Description (last modified by jdevrie)

I do not use the standard port numbers on my webdav server. Therefore I have specified a specific port number for webdav over HTTPS in cyberduck. When I use the option "Copy Web URL" I get the proper url. However when I use the option "open web url" the port number is not included in the url so that option does not work unless I insert the port number in te browser's URL line afterwards.

Attachments (2)

Image1.jpg (77.2 KB) - added by jdevrie on Apr 16, 2020 at 3:55:11 PM.
Screenshot of bookmark definition
Image2.jpg (209.4 KB) - added by jdevrie on Apr 16, 2020 at 3:58:13 PM.
Screenshot of Open web URL without custom port number

Download all attachments as: .zip

Change History (10)

comment:1 Changed on Apr 4, 2020 at 11:04:43 PM by jdevrie

  • Description modified (diff)
  • Summary changed from Open web url does not include portnumber in url to Open web url does not include port number in url

comment:2 Changed on Apr 15, 2020 at 8:04:37 PM by dkocher

  • Priority changed from high to normal
  • Severity changed from major to normal
  • Summary changed from Open web url does not include port number in url to Open web URL does not include custom port number

comment:3 Changed on Apr 16, 2020 at 10:21:38 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue. Configure the Web URL in the bookmark accordingly to include the port number.

comment:4 Changed on Apr 16, 2020 at 10:47:00 AM by jdevrie

I am getting this on all machines that connect to my server. The URL appears properly on the bookmark config page with the port otherwise I would not be able to connect at all. It also appears properly on the Copy URL entry but not on the open web URL entry. Maybe you can try it on my server. I created a test account for you;

Hostname: jdvl.nl webdav HTTPS port: 51006 userid: cyberduck pw: Ro1drigues$

Last edited on Apr 16, 2020 at 10:49:01 AM by jdevrie (previous) (diff)

comment:5 Changed on Apr 16, 2020 at 10:47:19 AM by jdevrie

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:6 Changed on Apr 16, 2020 at 1:46:37 PM by dkocher

Can you provide a screenshot of your bookmark configuration.

Changed on Apr 16, 2020 at 3:55:11 PM by jdevrie

Screenshot of bookmark definition

Changed on Apr 16, 2020 at 3:58:13 PM by jdevrie

Screenshot of Open web URL without custom port number

comment:7 Changed on Apr 16, 2020 at 4:27:18 PM by jdevrie

I just filled in the the field "Web URL" under "more options" with the url that includes the custom port number and the path that is specified in the path field. So I filled in "https://jdvl.nl:51006/video" That seems to overide the default url that is generated when you do not fill in anything in the "Web URL field. Now it works but that is counter intuitive. On the "Copy Url" option the custom port number and path is filled by cyberduck by default while on the default "Open URL this is not the case. This appears to me as very inconsistent in its behaviour.

I can understand that it will not fill in the port and path once you fill the "web url" field but it should be included it on the default generated url when you do not fill the "Web url" field. In fact when you look under copy URL it generates two defaults. One with the custom port number and path and one without. Personally I never use the latter since that doesn't work because it is never the proper URL because of that missing info.

So we should change this defects name to: Open URL does not include custom port number or path in default URL

Last edited on Apr 16, 2020 at 4:39:39 PM by jdevrie (previous) (diff)

comment:8 Changed on Apr 21, 2020 at 9:31:59 AM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

We include both the Origin URL with the port number you connect to in Cyberduck as well as the configured HTTP URL if any. Documentation ca be found in the wiki.

Note: See TracTickets for help on using tickets.
swiss made software