Cyberduck Mountain Duck CLI

#11034 closed defect (worksforme)

Cannot create archive - returns "Connection failed" dialog box that reads "Request failed."

Reported by: oceanjeremy Owned by: dkocher
Priority: normal Milestone:
Component: sftp Version: 7.3.0
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

First off, I can't give you a transcript from View → Toggle Log Drawer because that option doesn't exist in my version of Cyberduck. In fact, according to https://trac.cyberduck.io/ticket/104 the log drawer was discontinued in 2006. More than fourteen years ago.

But I can tell you what my issue is!

What I'm trying to do:

  • Create an archive of a file on the server.

What happens:

  • It returns a "Connection failed" dialog box that reads "Request failed."
  • It shows a spinning wheel of death next to the command on the bottom line.

Before you ask:

  • Yes I'm logged in SFTP / SSH.
  • Yes my server has a zip executable, at /usr/bin/zip

What I think might be the problem: Take a look at the command that Cyberduck sends to my server:

"cd /www\.nynbt\.org/web/content; zip -qr /www\.nynbt\.org/web/content/wp\-login\.php.zip wp\-login\.php"

I'm just an amateur when it comes to this kind of stuff, but I did notice that the command does not escape the period between "php.zip" ... could that be the issue?

Or is it something else? What's going on?

Attachments (2)

1-AttemptToArchive.png (668.7 KB) - added by oceanjeremy on Apr 23, 2020 at 7:47:42 PM.
Attempt to archive
2-ConnectionFailed-RequestFailed.png (246.9 KB) - added by oceanjeremy on Apr 23, 2020 at 7:48:51 PM.
Connection failed / Request failed

Download all attachments as: .zip

Change History (6)

Changed on Apr 23, 2020 at 7:47:42 PM by oceanjeremy

Attempt to archive

Changed on Apr 23, 2020 at 7:48:51 PM by oceanjeremy

Connection failed / Request failed

comment:1 Changed on May 22, 2020 at 9:52:11 AM by dkocher

  • Component changed from core to sftp
  • Owner set to dkocher

comment:2 Changed on May 22, 2020 at 9:55:35 AM by dkocher

I cannot reproduce the problem. Can you execute the command manually in a SSH terminal session or using Go → Send Command… to see if it works there.

comment:3 Changed on May 22, 2020 at 9:56:23 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:4 Changed on May 22, 2020 at 7:24:27 PM by oceanjeremy

Thanks for looking into this, I was just about to come back and close this ticket myself.

Turns out the issue was my web hosting service. They wouldn't let me SSH into the server, and told me there was no way to archive files using their file manager. Which was crazy because I have a WordPress plugin that backs up my website, and I could see right there in its logs that it found a zip executable in /usr/bin/zip and was using it just fine. The tech support folks with the hosting service said I had to write a .sh script and run it with a cron job to zip or unzip anything, but it didn't work. So I spent half an hour scheduling cron jobs and never got that avenue to function.

In the end I deployed my own VPS and canceled my account with the hosting service. Now I'm my own server admin!

Cyberduck works perfectly now — it archives / unarchives functionally. But of course now I can just SSH into the server to archive anything I want from the command line.

I'm never using shared hosting again.

Long story short: if any other Cyberduck users run into this issue it's probably a problem with their hosting service.

Note: See TracTickets for help on using tickets.
swiss made software