Cyberduck Mountain Duck CLI

#11038 closed defect (fixed)

PUTs fail to S3 with Request Error: Header "x-amz-content-sha256" set to the hex-encoded SHA256 hash ... AWS Version 4

Reported by: jamshid Owned by: dkocher
Priority: normal Milestone: 7.4.1
Component: s3 Version: 7.3.1
Severity: major Keywords:
Cc: Architecture:
Platform: macOS 10.15

Description (last modified by dkocher)

Something must be wrong with my macOS install? Writing a 100M file to Amazon S3 fails with:

Request Error: Header "x-amz-content-sha256" set to the hex-encoded SHA256 hash of the request payload is required for AWS Version 4 request signing, please set this on: PUT https://X.s3.amazonaws.com:443/test/duck_100M HTTP/1.1. Please contact your web hosting service provider for assistance.

I've reinstalled and confirmed Cyberduck 7.1.0 does not have this problem.

"defaults read ch.sudo.cyberduck" shows:

"s3.location" = "us-west-2"; "s3.signature.version" = AWS4HMACSHA256;

Attachments (1)

cyberduck-log-11038.txt (29.1 KB) - added by jamshid on May 26, 2020 at 8:12:36 PM.
log showing weird AWSV4 sig error

Download all attachments as: .zip

Change History (9)

comment:1 Changed on May 23, 2020 at 3:28:21 PM by dkocher

  • Description modified (diff)

I cannot reproduce this error. Can you please provide some log output.

Changed on May 26, 2020 at 8:12:36 PM by jamshid

log showing weird AWSV4 sig error

comment:2 Changed on May 26, 2020 at 8:35:40 PM by jamshid

Thank you for investigating. I attached logs though I don't see these menu items in my Cyberduck: Action → Include Info Messages and Action → Include Debug Messages

Hopefully the logs are still useful, let me know if you want me to test anything else or gather more logs.

comment:3 Changed on Jun 5, 2020 at 1:45:57 PM by dkocher

Can you let me know if you can still reproduce with version 7.4.

comment:4 Changed on Jun 8, 2020 at 5:18:48 PM by jamshid

Same error with 7.4.0. Do you want another set of logs, were the previous logs helpful? If it's something in my config maybe you could tell me what to clear or I could attach the file?

comment:5 Changed on Jun 9, 2020 at 8:08:12 PM by jamshid

Aha a breakthrough! It appears to be specific to certain files. Download this file (100M of NULs) then try uploading to an Amazon S3 bucket. https://jam.cloud.caringo.com/public/duck_100M You should now see the V4 signature error related to "x-amz-content-sha256".

A colleague verified the same error with a 100MB random bytes file, so it seems more about the size than contents.

dd if=/dev/urandom of=Desktop/test-100M.out bs=1024k count=100

Hopefully you can see the bug now, let me know if you need anything. Thanks!

comment:6 Changed on Jun 10, 2020 at 7:36:42 PM by dkocher

  • Milestone set to 8.0
  • Owner set to dkocher
  • Status changed from new to assigned

I can reproduce the bug which should only affects files with exactly 104857600B in file length.

comment:7 Changed on Jun 11, 2020 at 8:04:33 AM by yla

  • Resolution set to fixed
  • Status changed from assigned to closed

In r49377.

comment:8 Changed on Jun 15, 2020 at 7:49:05 PM by dkocher

  • Milestone changed from 8.0 to 7.4.1
Note: See TracTickets for help on using tickets.
swiss made software