Cyberduck Mountain Duck CLI

#11051 closed defect (duplicate)

Consumes huge amounts of memory when downloading a large online-only vault

Reported by: rootie Owned by: dkocher
Priority: high Milestone: 8.0
Component: onedrive Version: 7.3.1
Severity: critical Keywords:
Cc: Architecture: PPC
Platform: Mac OS X 10.5

Description

Hi,

there's a serious issue in Cyberduck that keeps one from downloading large contents from an online-only OneDrive vault (maybe others, too).

I've tried to download 50 GB of data. It started downloading but after approx 2 hours the system got sluggish and reported that there's not enough memory.

When the download starts then Cyberduck's memory usages rises and rises. You can easily see that in terminal using "top" as command.

It seems that buffers are not cleared properly.

Please analyze and fix this accordingly.

Thanks and best regards, rootie

Change History (8)

comment:1 Changed on May 22, 2020 at 10:39:08 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Please double check you are running version 7.3.1 which contains a memory usage fix.

comment:2 Changed on May 22, 2020 at 11:52:32 AM by rootie

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hi,

I've double checked and I can confirm that the issue is still there with 7.3.1. Maybe the memory usage fix even introduced the issue!

comment:3 Changed on May 22, 2020 at 12:37:43 PM by rootie

Hi again,

I've downloaded the previous version Cyberduck 7.3.0.32621 and can confirm that it WORKS there. Hence this must have been introduced with 7.3.1.

I'm quite sure that this memory fix does not work properly. With the old version the RAM memory usage stays < 500 MB during the whole download and does not increase permanently. It seems that every MB that Cyberduck is downloading with 7.3.1 is added to the RAM usage.

comment:4 Changed on May 22, 2020 at 1:22:57 PM by rootie

Small update: The RAM usage DOES increase with CyberDuck 7.3.0.32621 but not close as much as with 7.3.1. After downloading 17.5 GB from the online-only vault (OneDrive) CyberDuck 7.3.0.32621 consumes about 2,5 GB of RAM.

With 7.3.1 it would have consumed 17.5 GB.

comment:5 Changed on May 24, 2020 at 11:00:04 AM by dkocher

  • Summary changed from Cyberduck consumes huge amounts of memory when downloading a large online-only vault to Consumes huge amounts of memory when downloading a large online-only vault

comment:6 Changed on May 24, 2020 at 11:04:00 AM by dkocher

  • Component changed from core to onedrive

comment:7 Changed on May 26, 2020 at 8:33:20 AM by dkocher

If possible please follow the instructions in #11049#comment:4

comment:8 Changed on Jun 5, 2020 at 1:13:47 PM by dkocher

  • Milestone set to 8.0
  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software