Cyberduck Mountain Duck CLI

#11052 closed defect (fixed)

Cannot transfer files anymore to one server (upload or download) via FTPS (Explicit Auth TLS)

Reported by: razvanioan Owned by:
Priority: normal Milestone: 7.4
Component: ftp-tls Version: 7.3.0
Severity: normal Keywords:
Cc: Architecture: Intel
Platform:

Description

Being a webdevloper I always connect with different hosting servers.

One particular server (without cPanel, but custom managed) which is configured to connect via FTPS (Explicit Auth TLS) was working ok until 7.3.0 update.

Since the update I can:

  • connect to the server
  • browse files
  • delete files

I cannot:

  • upload files (it only puts an empty file, 0 kb and raises error 425, Connection failed 425 Unable to build data connection: Operation not permitted.)
  • create file (the same as above, empty file and the same error)
  • download / edit files (the same error)

Lates version 7.3.1 does the same

All the other servers / connections seem fine.

I've downloaded version 7.2.5 and it works.

With other clients (like latest Transmit) it's also working.

I suspect there might be some sensitive info in the updated TLS or someting.

That particular server is behind a proxypass, maybe this matters.

Change History (3)

comment:1 Changed on May 19, 2020 at 12:17:20 PM by lvogt

  • Resolution set to fixed
  • Status changed from new to closed

This is an issue with TLS 1.3. We've worked around it in r49234 by disabling TLS 1.3.
The workaround is included within the latest Snapshot.

comment:2 Changed on Jun 4, 2020 at 3:42:32 PM by dkocher

  • Milestone set to 7.4

comment:3 Changed on Jun 4, 2020 at 3:42:52 PM by dkocher

  • Component changed from core to ftp-tls
Note: See TracTickets for help on using tickets.
swiss made software